packages/net/gnunet/patches/100-fix-opus-and-pulse-library-detection.patch
Daniel Golle b924c3e001 gnunet: update to version 0.12.1
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
2019-12-29 14:18:45 +02:00

38 lines
1.7 KiB
Diff

diff --git a/configure.ac b/configure.ac
index e2c4dd39f..95053e672 100644
--- a/configure.ac
+++ b/configure.ac
@@ -803,10 +803,12 @@ AC_ARG_WITH(libpulse,
LDFLAGS="-L$with_libpulse/lib $LDFLAGS"
CPPFLAGS="-I$with_libpulse/include $CPPFLAGS"
AC_CHECK_HEADERS(pulse/simple.h,
- AC_CHECK_LIB([pulse],
- [pa_stream_peek],
- EXT_LIB_PATH="-L$with_libpulse/lib $EXT_LIB_PATH"
- pulse=1))
+ AC_CHECK_DECL([pa_stream_peek],
+ [pulse=1],
+ [],
+ [[
+ #include <pulse/stream.h>
+ ]]))
])
],
[AC_MSG_RESULT([--with-libpulse not specified])
@@ -846,10 +848,12 @@ AC_ARG_WITH(libopus,
LDFLAGS="-L$with_libopus/lib $LDFLAGS"
CPPFLAGS="-I$with_libopus/include $CPPFLAGS"
AC_CHECK_HEADERS(opus/opus.h,
- AC_CHECK_LIB([opus],
- [OPUS_SET_GAIN],
- EXT_LIB_PATH="-L$with_libopus/lib $EXT_LIB_PATH"
- opus=1))
+ AC_CHECK_DECL([OPUS_SET_GAIN],
+ [opus=1],
+ [],
+ [[
+ #include <opus/opus.h>
+ ]]))
])
],
[AC_MSG_RESULT([--with-libopus not specified])