gnunet: update to version 0.12.1
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
c14a88451a
commit
b924c3e001
2 changed files with 43 additions and 2 deletions
|
@ -2,11 +2,11 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=gnunet
|
||||
|
||||
PKG_VERSION:=0.12.0
|
||||
PKG_VERSION:=0.12.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/gnunet
|
||||
PKG_HASH:=2184ace2960e4757969f3cd6bc0dba6f136871bf7bcca5d80a7147bde0d2e0af
|
||||
PKG_HASH:=5553014dfa8b9aefa96fe83c6a8b8a84a28b30655df0ce283fd3e44a5a1b1f7e
|
||||
|
||||
PKG_LICENSE:=AGPL-3.0
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
@ -41,6 +41,9 @@ CONFIGURE_ARGS+= \
|
|||
--with-libunistring-prefix=$(STAGING_DIR)/usr \
|
||||
--with-microhttpd=$(STAGING_DIR)/usr
|
||||
|
||||
# upstream now provides --with-pulseaudio but doesn't detect rpath
|
||||
TARGET_LDFLAGS+= -Wl,-rpath-link=$(STAGING_DIR)/usr/lib/pulseaudio
|
||||
|
||||
define Package/gnunet/Default
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
|
|
|
@ -0,0 +1,38 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
index e2c4dd39f..95053e672 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -803,10 +803,12 @@ AC_ARG_WITH(libpulse,
|
||||
LDFLAGS="-L$with_libpulse/lib $LDFLAGS"
|
||||
CPPFLAGS="-I$with_libpulse/include $CPPFLAGS"
|
||||
AC_CHECK_HEADERS(pulse/simple.h,
|
||||
- AC_CHECK_LIB([pulse],
|
||||
- [pa_stream_peek],
|
||||
- EXT_LIB_PATH="-L$with_libpulse/lib $EXT_LIB_PATH"
|
||||
- pulse=1))
|
||||
+ AC_CHECK_DECL([pa_stream_peek],
|
||||
+ [pulse=1],
|
||||
+ [],
|
||||
+ [[
|
||||
+ #include <pulse/stream.h>
|
||||
+ ]]))
|
||||
])
|
||||
],
|
||||
[AC_MSG_RESULT([--with-libpulse not specified])
|
||||
@@ -846,10 +848,12 @@ AC_ARG_WITH(libopus,
|
||||
LDFLAGS="-L$with_libopus/lib $LDFLAGS"
|
||||
CPPFLAGS="-I$with_libopus/include $CPPFLAGS"
|
||||
AC_CHECK_HEADERS(opus/opus.h,
|
||||
- AC_CHECK_LIB([opus],
|
||||
- [OPUS_SET_GAIN],
|
||||
- EXT_LIB_PATH="-L$with_libopus/lib $EXT_LIB_PATH"
|
||||
- opus=1))
|
||||
+ AC_CHECK_DECL([OPUS_SET_GAIN],
|
||||
+ [opus=1],
|
||||
+ [],
|
||||
+ [[
|
||||
+ #include <opus/opus.h>
|
||||
+ ]]))
|
||||
])
|
||||
],
|
||||
[AC_MSG_RESULT([--with-libopus not specified])
|
Loading…
Reference in a new issue