packages/libs/ldns/patches/001-compile-for-darwin.patch
Rosen Penev a89a876de9
ldns: fix compilation without deprecated APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-08-04 19:11:25 -07:00

11 lines
504 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -861,7 +861,7 @@ AC_ARG_WITH(xcode-sdk, AC_HELP_STRING([--with-xcode-sdk],
[],[with_xcode_sdk="yes"])
if test "x_$with_xcode_sdk" != "x_no" ; then
# check OSX deployment target, if needed
- if echo $build_os | grep darwin > /dev/null; then
+ if echo $target_os | grep darwin > /dev/null; then
sdk_p=`xcode-select -print-path`;
if test "x_$with_xcode_sdk" = "x_yes" ; then
sdk_v="$( /usr/bin/xcrun --show-sdk-version 2>/dev/null )"