ldns: fix compilation without deprecated APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
7f620401af
commit
a89a876de9
3 changed files with 20 additions and 2 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=ldns
|
||||
PKG_VERSION:=1.7.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.nlnetlabs.nl/downloads/ldns
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -881,7 +881,7 @@ AC_ARG_WITH(xcode-sdk, AC_HELP_STRING([--with-xcode-sdk],
|
||||
@@ -861,7 +861,7 @@ AC_ARG_WITH(xcode-sdk, AC_HELP_STRING([--with-xcode-sdk],
|
||||
[],[with_xcode_sdk="yes"])
|
||||
if test "x_$with_xcode_sdk" != "x_no" ; then
|
||||
# check OSX deployment target, if needed
|
||||
|
|
18
libs/ldns/patches/030-signzone.patch
Normal file
18
libs/ldns/patches/030-signzone.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- a/examples/ldns-signzone.c
|
||||
+++ b/examples/ldns-signzone.c
|
||||
@@ -535,6 +535,7 @@ init_openssl_engine ( const char * const id )
|
||||
static void
|
||||
shutdown_openssl ( ENGINE * const e )
|
||||
{
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
|
||||
if ( e != NULL ) {
|
||||
ENGINE_free ( e );
|
||||
ENGINE_cleanup ();
|
||||
@@ -544,6 +545,7 @@ shutdown_openssl ( ENGINE * const e )
|
||||
EVP_cleanup ();
|
||||
CRYPTO_cleanup_all_ex_data ();
|
||||
ERR_free_strings ();
|
||||
+#endif
|
||||
}
|
||||
#endif
|
||||
|
Loading…
Reference in a new issue