Werror is normally passed with pkgconfig headers. Remove it. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
359 B
Diff
11 lines
359 B
Diff
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -61,7 +61,7 @@ COMMON_TESTING_PROTOBUF_FLAGS = $(COMMON
|
|
|
|
# The generated protobuf files don't compile with -Werror on win32 so we
|
|
# disable fatal warnings on WIN32.
|
|
-if ! USING_WIN32
|
|
+if USING_WIN32
|
|
if FATAL_WARNINGS
|
|
COMMON_CXXFLAGS += -Werror
|
|
COMMON_PROTOBUF_CXXFLAGS += -Werror -Wno-error=unused-parameter \
|