ola: fix compilation with older clang
Werror is normally passed with pkgconfig headers. Remove it. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
457dcc5d5b
commit
b2989d1c1d
2 changed files with 12 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=ola
|
||||
PKG_VERSION:=0.10.8
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/OpenLightingProject/ola/tar.gz/$(PKG_VERSION)?
|
||||
|
|
11
net/ola/patches/010-no-werror.patch
Normal file
11
net/ola/patches/010-no-werror.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -61,7 +61,7 @@ COMMON_TESTING_PROTOBUF_FLAGS = $(COMMON
|
||||
|
||||
# The generated protobuf files don't compile with -Werror on win32 so we
|
||||
# disable fatal warnings on WIN32.
|
||||
-if ! USING_WIN32
|
||||
+if USING_WIN32
|
||||
if FATAL_WARNINGS
|
||||
COMMON_CXXFLAGS += -Werror
|
||||
COMMON_PROTOBUF_CXXFLAGS += -Werror -Wno-error=unused-parameter \
|
Loading…
Reference in a new issue