p11-kit: Fix compilation with uClibc-ng
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
8897ea4d51
commit
f443d9eb13
2 changed files with 17 additions and 2 deletions
|
@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=p11-kit
|
||||
PKG_VERSION:=0.23.16.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://github.com/p11-glue/p11-kit/releases/download/$(PKG_VERSION)
|
||||
PKG_HASH:=4b34e92ae36fa493e0d94366c767f06d5f9951e3d8581d10fd935d738db1574d
|
||||
|
||||
PKG_MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
|
||||
PKG_LICENSE:=BSD-3c
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
|
15
libs/p11-kit/patches/010-uclibc.patch
Normal file
15
libs/p11-kit/patches/010-uclibc.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- a/common/compat.c
|
||||
+++ b/common/compat.c
|
||||
@@ -97,8 +97,12 @@
|
||||
#include <unistd.h>
|
||||
|
||||
#if defined (HAVE_PROGRAM_INVOCATION_SHORT_NAME) && !HAVE_DECL_PROGRAM_INVOCATION_SHORT_NAME
|
||||
+#ifdef __UCLIBC__
|
||||
+extern const char *program_invocation_short_name;
|
||||
+#else
|
||||
extern char *program_invocation_short_name;
|
||||
#endif
|
||||
+#endif
|
||||
|
||||
#if defined (HAVE___PROGNAME) && !HAVE_DECL___PROGNAME
|
||||
extern char *__progname;
|
Loading…
Reference in a new issue