diff --git a/libs/p11-kit/Makefile b/libs/p11-kit/Makefile
index 11ba9a4c8..ef48b76a9 100644
--- a/libs/p11-kit/Makefile
+++ b/libs/p11-kit/Makefile
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=p11-kit
 PKG_VERSION:=0.23.16.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/p11-glue/p11-kit/releases/download/$(PKG_VERSION)
 PKG_HASH:=4b34e92ae36fa493e0d94366c767f06d5f9951e3d8581d10fd935d738db1574d
 
 PKG_MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
-PKG_LICENSE:=BSD-3c
+PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=COPYING
 
 PKG_BUILD_PARALLEL:=1
diff --git a/libs/p11-kit/patches/010-uclibc.patch b/libs/p11-kit/patches/010-uclibc.patch
new file mode 100644
index 000000000..642fdb4e4
--- /dev/null
+++ b/libs/p11-kit/patches/010-uclibc.patch
@@ -0,0 +1,15 @@
+--- a/common/compat.c
++++ b/common/compat.c
+@@ -97,8 +97,12 @@
+ #include <unistd.h>
+ 
+ #if defined (HAVE_PROGRAM_INVOCATION_SHORT_NAME) && !HAVE_DECL_PROGRAM_INVOCATION_SHORT_NAME
++#ifdef __UCLIBC__
++extern const char *program_invocation_short_name;
++#else
+ extern char *program_invocation_short_name;
+ #endif
++#endif
+ 
+ #if defined (HAVE___PROGNAME) && !HAVE_DECL___PROGNAME
+ extern char *__progname;