kea: Fix compilation without deprecated OpenSSL APIs

Forgot to add this one to the last pull request.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 54d7bc119d)
This commit is contained in:
Rosen Penev 2019-07-03 20:48:56 -07:00
parent 09ea6f0325
commit efde7c454e
No known key found for this signature in database
GPG key ID: 36D31CFA845F0E3B
2 changed files with 12 additions and 1 deletions

View file

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kea
PKG_VERSION:=1.5.0
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)

View file

@ -0,0 +1,11 @@
--- a/src/lib/cryptolink/openssl_link.cc
+++ b/src/lib/cryptolink/openssl_link.cc
@@ -79,7 +79,7 @@ CryptoLink::initialize() {
std::string
CryptoLink::getVersion() {
- return (SSLeay_version(SSLEAY_VERSION));
+ return (OpenSSL_version(OPENSSL_VERSION));
}
} // namespace cryptolink