kea: Fix compilation without deprecated OpenSSL APIs
Forgot to add this one to the last pull request. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
50abfa2fd7
commit
54d7bc119d
2 changed files with 12 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=kea
|
||||
PKG_VERSION:=1.5.0
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://ftp.isc.org/isc/kea/$(PKG_VERSION)
|
||||
|
|
11
net/kea/patches/010-openssl-deprecated.patch
Normal file
11
net/kea/patches/010-openssl-deprecated.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/lib/cryptolink/openssl_link.cc
|
||||
+++ b/src/lib/cryptolink/openssl_link.cc
|
||||
@@ -79,7 +79,7 @@ CryptoLink::initialize() {
|
||||
|
||||
std::string
|
||||
CryptoLink::getVersion() {
|
||||
- return (SSLeay_version(SSLEAY_VERSION));
|
||||
+ return (OpenSSL_version(OPENSSL_VERSION));
|
||||
}
|
||||
|
||||
} // namespace cryptolink
|
Loading…
Reference in a new issue