tcsh: Update to 6.22.02

Updated URL list. Changed to HTTPS also.

Added PKG_BUILD_PARALLEL for faster compilation.

Added PKG_INSTALL as is standard with most packages.

Small optimization to shell script.

Added two patches to fix compilation. Refreshed the other one.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
Rosen Penev 2020-01-02 22:27:19 -08:00
parent e020c10eb2
commit efc94a457c
No known key found for this signature in database
GPG key ID: 36D31CFA845F0E3B
4 changed files with 45 additions and 15 deletions

View file

@ -7,32 +7,36 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=tcsh PKG_NAME:=tcsh
PKG_VERSION:=6.20.00 PKG_VERSION:=6.22.02
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:= \ PKG_SOURCE_URL:= \
http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/ \ https://astron.com/pub/tcsh/ \
http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/old/ \ https://astron.com/pub/tcsh/old \
ftp://ftp.astron.com/pub/tcsh/ \ https://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh \
ftp://ftp.astron.com/pub/tcsh/old https://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/old
PKG_HASH:=b89de7064ab54dac454a266cfe5d8bf66940cb5ed048d0c30674ea62e7ecef9d PKG_HASH:=ed287158ca1b00ba477e8ea57bac53609838ebcfd05fcb05ca95021b7ebe885b
PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
PKG_LICENSE:=BSD-3-Clause PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=Copyright PKG_LICENSE_FILES:=Copyright
PKG_CPE_ID:=cpe:/a:tcsh:tcsh PKG_CPE_ID:=cpe:/a:tcsh:tcsh
PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com> PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
define Package/tcsh define Package/tcsh
SECTION:=utils SECTION:=utils
CATEGORY:=Utilities CATEGORY:=Utilities
SUBMENU:=Shells SUBMENU:=Shells
TITLE:=Enhanced Berkeley UNIX C shell TITLE:=Enhanced Berkeley UNIX C shell
DEPENDS:=+libncurses DEPENDS:=+libncurses $(ICONV_DEPENDS)
URL:=http://www.tcsh.org/ URL:=https://www.tcsh.org/
endef endef
define Package/tcsh/description define Package/tcsh/description
@ -48,14 +52,15 @@ endef
define Package/tcsh/postinst define Package/tcsh/postinst
#!/bin/sh #!/bin/sh
grep tcsh $${IPKG_INSTROOT}/etc/shells || \ grep tcsh $${IPKG_INSTROOT}/etc/shells || { \
echo "/bin/tcsh" >> $${IPKG_INSTROOT}/etc/shells echo "/bin/tcsh"
echo "/bin/csh" >> $${IPKG_INSTROOT}/etc/shells echo "/bin/csh"
} >> $${IPKG_INSTROOT}/etc/shells
endef endef
define Package/tcsh/install define Package/tcsh/install
$(INSTALL_DIR) $(1)/bin $(INSTALL_DIR) $(1)/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tcsh $(1)/bin/ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tcsh $(1)/bin/
ln -sf tcsh $(1)/bin/csh ln -sf tcsh $(1)/bin/csh
endef endef

View file

@ -1,6 +1,6 @@
--- a/config_f.h --- a/config_f.h
+++ b/config_f.h +++ b/config_f.h
@@ -139,11 +139,8 @@ @@ -138,11 +138,8 @@
* This can be much slower and no memory statistics will be * This can be much slower and no memory statistics will be
* provided. * provided.
*/ */

View file

@ -0,0 +1,14 @@
--- a/ed.inputl.c
+++ b/ed.inputl.c
@@ -668,9 +668,9 @@ int
GetCmdChar(Char ch)
{
#ifndef WINNT_NATIVE // We use more than 256 for various extended keys
- wint_t c = ch & CHAR;
+ Char c = ch & CHAR;
#else
- wint_t c = ch;
+ Char c = ch;
#endif
return c < NT_NUM_KEYS ? CurrentKeyMap[c] : F_INSERT;
}

View file

@ -0,0 +1,11 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -447,7 +447,7 @@ pure:$(P) ${OBJS}
gethost: gethost.c sh.err.h tc.const.h sh.h
rm -f gethost
- ${CC_FOR_GETHOST} -o gethost ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} $(srcdir)/gethost.c
+ ${CC_FOR_GETHOST} -o gethost $(srcdir)/gethost.c
tc.defs.c: gethost host.defs
@rm -f $@.tmp