net/mosquitto: Patch QoS 2 in flight bug
Patched until new upstream release is available. Patch sourced from upstream. Signed-off-by: Karl Palsson <karlp@remake.is>
This commit is contained in:
parent
b3349c6e13
commit
ee274e64f9
2 changed files with 13 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=mosquitto
|
||||
PKG_VERSION:=1.4.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE.txt
|
||||
|
||||
|
|
12
net/mosquitto/patches/101-qos2-inflight.patch
Normal file
12
net/mosquitto/patches/101-qos2-inflight.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff --git a/lib/mosquitto.c b/lib/mosquitto.c
|
||||
index bd9dbd3..7314248 100644
|
||||
--- a/lib/mosquitto.c
|
||||
+++ b/lib/mosquitto.c
|
||||
@@ -594,7 +594,6 @@ int mosquitto_publish(struct mosquitto *mosq, int *mid, const char *topic, int p
|
||||
pthread_mutex_lock(&mosq->out_message_mutex);
|
||||
_mosquitto_message_queue(mosq, message, mosq_md_out);
|
||||
if(mosq->max_inflight_messages == 0 || mosq->inflight_messages < mosq->max_inflight_messages){
|
||||
- mosq->inflight_messages++;
|
||||
if(qos == 1){
|
||||
message->state = mosq_ms_wait_for_puback;
|
||||
}else if(qos == 2){
|
Loading…
Reference in a new issue