net/mosquitto: Bump to 1.4.1

Some useful fixes:
http://mosquitto.org/2015/04/version-1-4-1-released/

Drops a patch that has been rolled into upstream.

Signed-off-by: Karl Palsson <karlp@remake.is>
This commit is contained in:
Karl Palsson 2015-04-10 14:36:52 +00:00
parent de1953e8d4
commit b3349c6e13
2 changed files with 3 additions and 16 deletions

View file

@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mosquitto
PKG_VERSION:=1.4
PKG_RELEASE:=2
PKG_VERSION:=1.4.1
PKG_RELEASE:=1
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.txt
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://mosquitto.org/files/source/
PKG_MD5SUM:=cd879f5964311501ba8e2275add71484
PKG_MD5SUM:=46008028563eb750c6aa93281ab2e181
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk

View file

@ -1,13 +0,0 @@
diff --git a/src/websockets.c b/src/websockets.c
index 95f8a81..cf2b5e7 100644
--- a/src/websockets.c
+++ b/src/websockets.c
@@ -72,7 +72,7 @@ struct libws_http_data {
FILE *fptr;
};
-#ifndef HTTP_STATUS_NOT_FOUND
+#ifndef LWS_FEATURE_SERVE_HTTP_FILE_HAS_OTHER_HEADERS_ARG
/* This is libwebsockets 1.2.x or earlier, we have to degrade our capabilities.
* Once lws 1.3 is widely available this should be removed. */
# define LWS_IS_OLD