libftdi: fix packagekit when useing cmake
Based on upstream commit by Thomas Jarosch based on Alexander's patch. More info: https://github.com/openwrt/packages/pull/690 Signed-off-by: Alexander Couzens <lynxis@fe80.eu> Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
4f34750e81
commit
d54b357dfc
3 changed files with 31 additions and 2 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=libftdi
|
||||
PKG_VERSION:=0.20
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -43,7 +43,7 @@ IF(CMAKE_SIZEOF_VOID_P EQUAL 4)
|
||||
@@ -44,7 +44,7 @@ IF(CMAKE_SIZEOF_VOID_P EQUAL 4)
|
||||
SET(LIB_SUFFIX "")
|
||||
SET(PACK_ARCH "")
|
||||
ELSE(CMAKE_SIZEOF_VOID_P EQUAL 8)
|
||||
|
|
29
libs/libftdi/patches/101-fix-cmake-version-packagekit.patch
Normal file
29
libs/libftdi/patches/101-fix-cmake-version-packagekit.patch
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -1,9 +1,12 @@
|
||||
# Project
|
||||
project(libftdi)
|
||||
+set(PACKAGE libftdi)
|
||||
set(MAJOR_VERSION 0)
|
||||
set(MINOR_VERSION 20)
|
||||
+set(VERSION ${VERSION_STRING})
|
||||
set(VERSION_STRING ${MAJOR_VERSION}.${MINOR_VERSION})
|
||||
-SET(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}")
|
||||
+set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}")
|
||||
+set(top_srcdir ${CMAKE_SOURCE_DIR})
|
||||
|
||||
# CMake
|
||||
if("${CMAKE_BUILD_TYPE}" STREQUAL "")
|
||||
@@ -98,12 +101,6 @@ option(DOCUMENTATION "Generate API docum
|
||||
|
||||
find_package(Doxygen)
|
||||
if(DOCUMENTATION AND DOXYGEN_FOUND)
|
||||
-
|
||||
- # Set variables
|
||||
- set(PACKAGE libftdi)
|
||||
- set(VERSION ${VERSION_STRING})
|
||||
- set(top_srcdir ${CMAKE_SOURCE_DIR})
|
||||
-
|
||||
# Find doxy config
|
||||
message(STATUS "Doxygen found.")
|
||||
set(DOXY_DIR "${CMAKE_SOURCE_DIR}/doc")
|
Loading…
Reference in a new issue