diff --git a/libs/libftdi/Makefile b/libs/libftdi/Makefile
index c146e9918..a98601432 100644
--- a/libs/libftdi/Makefile
+++ b/libs/libftdi/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libftdi
 PKG_VERSION:=0.20
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/
diff --git a/libs/libftdi/patches/100-fix-x86_64-build.patch b/libs/libftdi/patches/100-fix-x86_64-build.patch
index 9a9da9a6c..2460cb163 100644
--- a/libs/libftdi/patches/100-fix-x86_64-build.patch
+++ b/libs/libftdi/patches/100-fix-x86_64-build.patch
@@ -1,6 +1,6 @@
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -43,7 +43,7 @@ IF(CMAKE_SIZEOF_VOID_P EQUAL 4)
+@@ -44,7 +44,7 @@ IF(CMAKE_SIZEOF_VOID_P EQUAL 4)
      SET(LIB_SUFFIX "")
      SET(PACK_ARCH "")
    ELSE(CMAKE_SIZEOF_VOID_P EQUAL 8)
diff --git a/libs/libftdi/patches/101-fix-cmake-version-packagekit.patch b/libs/libftdi/patches/101-fix-cmake-version-packagekit.patch
new file mode 100644
index 000000000..e6861dcd9
--- /dev/null
+++ b/libs/libftdi/patches/101-fix-cmake-version-packagekit.patch
@@ -0,0 +1,29 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,9 +1,12 @@
+ # Project
+ project(libftdi)
++set(PACKAGE libftdi)
+ set(MAJOR_VERSION 0)
+ set(MINOR_VERSION 20)
++set(VERSION ${VERSION_STRING})
+ set(VERSION_STRING ${MAJOR_VERSION}.${MINOR_VERSION})
+-SET(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}")
++set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}")
++set(top_srcdir ${CMAKE_SOURCE_DIR})
+ 
+ # CMake
+ if("${CMAKE_BUILD_TYPE}" STREQUAL "")
+@@ -98,12 +101,6 @@ option(DOCUMENTATION "Generate API docum
+ 
+ find_package(Doxygen)
+ if(DOCUMENTATION AND DOXYGEN_FOUND)
+-
+-   # Set variables
+-   set(PACKAGE libftdi)
+-   set(VERSION ${VERSION_STRING})
+-   set(top_srcdir ${CMAKE_SOURCE_DIR})
+-
+    # Find doxy config
+    message(STATUS "Doxygen found.")
+    set(DOXY_DIR "${CMAKE_SOURCE_DIR}/doc")