rp-pppoe: redo glibc patch
Previous fix broke compilation with kernel < 4.8
Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
(cherry-picked from e40d67a48f
)
This commit is contained in:
parent
5327a95d66
commit
ca99a333e5
2 changed files with 5 additions and 5 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=rp-pppoe
|
PKG_NAME:=rp-pppoe
|
||||||
PKG_VERSION:=3.12
|
PKG_VERSION:=3.12
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=6
|
||||||
PKG_MAINTAINER:=Daniel Dickinson <lede@cshore.thecshore.com>
|
PKG_MAINTAINER:=Daniel Dickinson <lede@cshore.thecshore.com>
|
||||||
PKG_LICENSE:=LGPL-2.0+
|
PKG_LICENSE:=LGPL-2.0+
|
||||||
|
|
||||||
|
|
|
@ -1,12 +1,12 @@
|
||||||
--- a/src/pppoe.h
|
--- a/src/pppoe.h
|
||||||
+++ b/src/pppoe.h
|
+++ b/src/pppoe.h
|
||||||
@@ -131,7 +131,9 @@ typedef unsigned long UINT32_t;
|
@@ -132,6 +132,9 @@ typedef unsigned long UINT32_t;
|
||||||
#include <linux/if_ether.h>
|
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
+#ifndef __GLIBC__
|
|
||||||
#include <netinet/in.h>
|
#include <netinet/in.h>
|
||||||
+#endif
|
+/* avoid redefinitions if <linux/in.h> and <linux/in6.h> get included. */
|
||||||
|
+#define _LINUX_IN_H
|
||||||
|
+#define _LINUX_IN6_H
|
||||||
|
|
||||||
#ifdef HAVE_NETINET_IF_ETHER_H
|
#ifdef HAVE_NETINET_IF_ETHER_H
|
||||||
#include <sys/types.h>
|
#include <sys/types.h>
|
||||||
|
|
Loading…
Reference in a new issue