rp-pppoe: Fixed compilation with glibc

Do not inlcude <netinet/in.h> when using glibc to avoid various
redefinitions.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
(cherry-picked from 0c995cabe7)
This commit is contained in:
Eneas U de Queiroz 2018-05-23 14:24:35 -03:00 committed by Rosen Penev
parent 19d101bd22
commit 5327a95d66
No known key found for this signature in database
GPG key ID: 36D31CFA845F0E3B
2 changed files with 13 additions and 1 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=rp-pppoe
PKG_VERSION:=3.12
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_MAINTAINER:=Daniel Dickinson <lede@cshore.thecshore.com>
PKG_LICENSE:=LGPL-2.0+

View file

@ -0,0 +1,12 @@
--- a/src/pppoe.h
+++ b/src/pppoe.h
@@ -131,7 +131,9 @@ typedef unsigned long UINT32_t;
#include <linux/if_ether.h>
#endif
+#ifndef __GLIBC__
#include <netinet/in.h>
+#endif
#ifdef HAVE_NETINET_IF_ETHER_H
#include <sys/types.h>