Merge pull request #1835 from hnyman/collectd-fix-parallel
collectd: backport parallel build fix from upstream
This commit is contained in:
commit
c527219c9d
1 changed files with 17 additions and 0 deletions
17
utils/collectd/patches/500-upstream-parallel-build-fix.patch
Normal file
17
utils/collectd/patches/500-upstream-parallel-build-fix.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Backport of 780e6a76021a240e95007a04b723d827120afa95
|
||||
Subject: [PATCH] build: add libavltree, libcommon & libheap dependencies
|
||||
|
||||
Otherwise it can break on very parallel builds since collectd link time
|
||||
arrives before one or more of these were built.
|
||||
|
||||
--- a/src/daemon/Makefile.am
|
||||
+++ b/src/daemon/Makefile.am
|
||||
@@ -49,7 +49,7 @@ collectd_CPPFLAGS = $(AM_CPPFLAGS) $(LT
|
||||
collectd_CFLAGS = $(AM_CFLAGS)
|
||||
collectd_LDFLAGS = -export-dynamic
|
||||
collectd_LDADD = libavltree.la libcommon.la libheap.la -lm
|
||||
-collectd_DEPENDENCIES =
|
||||
+collectd_DEPENDENCIES = libavltree.la libcommon.la libheap.la
|
||||
|
||||
# Link to these libraries..
|
||||
if BUILD_WITH_LIBRT
|
Loading…
Reference in a new issue