collectd: backport parallel build fix from upstream
Backport a fix for parallel build from upstream,
where it has been commited to both trunk and 5.5 branch.
https://github.com/collectd/collectd/issues/1146
780e6a7602
Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
2817f1d920
commit
e2699e23f6
1 changed files with 17 additions and 0 deletions
17
utils/collectd/patches/500-upstream-parallel-build-fix.patch
Normal file
17
utils/collectd/patches/500-upstream-parallel-build-fix.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Backport of 780e6a76021a240e95007a04b723d827120afa95
|
||||
Subject: [PATCH] build: add libavltree, libcommon & libheap dependencies
|
||||
|
||||
Otherwise it can break on very parallel builds since collectd link time
|
||||
arrives before one or more of these were built.
|
||||
|
||||
--- a/src/daemon/Makefile.am
|
||||
+++ b/src/daemon/Makefile.am
|
||||
@@ -49,7 +49,7 @@ collectd_CPPFLAGS = $(AM_CPPFLAGS) $(LT
|
||||
collectd_CFLAGS = $(AM_CFLAGS)
|
||||
collectd_LDFLAGS = -export-dynamic
|
||||
collectd_LDADD = libavltree.la libcommon.la libheap.la -lm
|
||||
-collectd_DEPENDENCIES =
|
||||
+collectd_DEPENDENCIES = libavltree.la libcommon.la libheap.la
|
||||
|
||||
# Link to these libraries..
|
||||
if BUILD_WITH_LIBRT
|
Loading…
Reference in a new issue