net/lftp: upgrade to version 4.6.0

Signed-off-by: Federico Di Marco <fededim@gmail.com>
This commit is contained in:
Rupan 2014-12-13 18:15:09 +01:00
parent 0dcfc24c04
commit b19ccaeac5
2 changed files with 2 additions and 14 deletions

View file

@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lftp
PKG_VERSION:=4.5.5
PKG_VERSION:=4.6.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://lftp.yar.ru/ftp \ http://lftp.cybermirror.org \ http://lftp.cybermirror.org/old
PKG_MD5SUM:=e58fc886e3d7c6d994de5ce51de46087
PKG_MD5SUM:=fc5f4e3b45c9011a193eb8c0c12eb2eb
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk

View file

@ -1,12 +0,0 @@
--- a/src/ftpclass.cc
+++ b/src/ftpclass.cc
@@ -1071,7 +1071,9 @@ Ftp::Connection::~Connection()
control_send=0;
control_recv=0;
+#if USE_SSL
control_ssl=0; // ssl should be freed after send/recv
+#endif
if(control_sock!=-1)
{