diff --git a/net/lftp/Makefile b/net/lftp/Makefile
index e2aa28cd0..ea0aef1ee 100644
--- a/net/lftp/Makefile
+++ b/net/lftp/Makefile
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lftp
-PKG_VERSION:=4.5.5
+PKG_VERSION:=4.6.0
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://lftp.yar.ru/ftp \ http://lftp.cybermirror.org \ http://lftp.cybermirror.org/old
-PKG_MD5SUM:=e58fc886e3d7c6d994de5ce51de46087
+PKG_MD5SUM:=fc5f4e3b45c9011a193eb8c0c12eb2eb
 
 include $(INCLUDE_DIR)/uclibc++.mk
 include $(INCLUDE_DIR)/package.mk
diff --git a/net/lftp/patches/010-main_code_fix.patch b/net/lftp/patches/010-main_code_fix.patch
deleted file mode 100644
index 280c96bd1..000000000
--- a/net/lftp/patches/010-main_code_fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/ftpclass.cc
-+++ b/src/ftpclass.cc
-@@ -1071,7 +1071,9 @@ Ftp::Connection::~Connection()
- 
-    control_send=0;
-    control_recv=0;
-+#if USE_SSL
-    control_ssl=0; // ssl should be freed after send/recv
-+#endif
- 
-    if(control_sock!=-1)
-    {