Merge pull request #11807 from jefferyto/seafile-7.1.3
seafile-server (and related packages): Update to 7.1.3
This commit is contained in:
commit
97572b6716
6 changed files with 17 additions and 33 deletions
|
@ -9,17 +9,20 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=libsearpc
|
||||
PKG_VERSION:=3.2.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/libsearpc/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=c479d85e405674c3450eac040abe143af5a9fafe7f1b74926e2a05280ab5420e
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/haiwen/libsearpc.git
|
||||
PKG_SOURCE_VERSION:=d1fd7518a20b25766ff98d6fde6e40c63626ca0d
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(call version_abbrev,$(PKG_SOURCE_VERSION))
|
||||
PKG_MIRROR_HASH:=ee8b8b50b480afbcb71bd73cd9c2a96cfa72e9dafaf5773574adbf348e49a0d4
|
||||
|
||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_LICENSE_FILES:=LICENSE.txt
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
From 9b2e2dc65213fb22ed400dc54e4c2279564df62b Mon Sep 17 00:00:00 2001
|
||||
From: ly1217 <yu.liu@seafile.com>
|
||||
Date: Thu, 31 Oct 2019 00:31:38 -0700
|
||||
Subject: [PATCH] Fix memory leak.
|
||||
|
||||
---
|
||||
lib/searpc-named-pipe-transport.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
--- a/lib/searpc-named-pipe-transport.c
|
||||
+++ b/lib/searpc-named-pipe-transport.c
|
||||
@@ -377,6 +377,7 @@ void searpc_free_client_with_pipe_transp
|
||||
close(pipe_client->pipe_fd);
|
||||
#endif
|
||||
g_free (pipe_client);
|
||||
+ g_free (data->service);
|
||||
g_free (data);
|
||||
searpc_client_free (client);
|
||||
}
|
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=seafile-ccnet
|
||||
PKG_VERSION:=7.1.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=7.1.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/ccnet-server/tar.gz/v$(PKG_VERSION)-server?
|
||||
PKG_HASH:=32d3d7290415497c52ab407a64468538662dde81ccd139b6e4499e3f2c5b8d4b
|
||||
PKG_HASH:=148d9b1af9218943de310f3f2e29e542e7279dbfba307a1cdd894bf8b7faf2e8
|
||||
|
||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
||||
PKG_LICENSE:=AGPL-3.0-only
|
||||
|
|
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=seafile-seahub
|
||||
PKG_VERSION:=7.1.2
|
||||
PKG_VERSION:=7.1.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seahub/tar.gz/v$(PKG_VERSION)-server?
|
||||
PKG_HASH:=647dca870c996ed00844d3bf45bc15f22fdf5268cfd3ac4c0dd9e4c15360361d
|
||||
PKG_HASH:=a2cf1ad1ff357b06c112f3f80e2e4a2ef109813496c96afc309449f6915e8797
|
||||
|
||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
|
|
|
@ -9,7 +9,7 @@
|
|||
os.path.join(PROJECT_ROOT, 'seahub/templates'),
|
||||
],
|
||||
'APP_DIRS': True,
|
||||
@@ -627,7 +627,7 @@ CAPTCHA_IMAGE_SIZE = (90, 42)
|
||||
@@ -630,7 +630,7 @@ CAPTCHA_IMAGE_SIZE = (90, 42)
|
||||
ENABLE_THUMBNAIL = True
|
||||
|
||||
# Absolute filesystem path to the directory that will hold thumbnail files.
|
||||
|
@ -18,7 +18,7 @@
|
|||
if os.path.exists(SEAHUB_DATA_ROOT):
|
||||
THUMBNAIL_ROOT = os.path.join(SEAHUB_DATA_ROOT, 'thumbnail')
|
||||
else:
|
||||
@@ -790,7 +790,7 @@ except ImportError:
|
||||
@@ -793,7 +793,7 @@ except ImportError:
|
||||
pass
|
||||
else:
|
||||
# In server release, sqlite3 db file is <topdir>/seahub.db
|
||||
|
|
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=seafile-server
|
||||
PKG_VERSION:=7.1.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=7.1.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seafile-server/tar.gz/v$(PKG_VERSION)-server?
|
||||
PKG_HASH:=30b972d17eb13da28f4dffcbabd2a2a4a7426a017f694e0fb8440e93fd5bd355
|
||||
PKG_HASH:=79f7722a34c304adb78462194e64d6a610bd5ee40def37f4e4cdf5befed44fcd
|
||||
|
||||
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
|
||||
PKG_LICENSE:=AGPL-3.0-only
|
||||
|
|
Loading…
Reference in a new issue