Merge pull request #11804 from VolunteerComputingHelp/master

boinc: FTBFS: avoiding unexpected dependencies
This commit is contained in:
Hannu Nyman 2020-04-08 08:23:06 +03:00 committed by GitHub
commit e3e464ed12
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23

View file

@ -0,0 +1,15 @@
Index: boinc-client_release-7.16-7.16.5/configure.ac
===================================================================
--- boinc-client_release-7.16-7.16.5.orig/configure.ac
+++ boinc-client_release-7.16-7.16.5/configure.ac
@@ -506,8 +506,10 @@ SAH_CHECK_LIB([dl], [dlopen],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
SAH_CHECK_LIB([nsl], [gethostbyname],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
+if test "${enable_manager}" = yes ; then
SAH_CHECK_LIB([freetype], [fopen],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
+fi
SAH_CHECK_LIB([socket], [bind],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
SAH_CHECK_LIB([z], [gzopen],