Merge pull request #14670 from jonathanunderwood/openwrt-19.07-cherry-pick
[19.07] getdns: cherry pick recent fixes from master
This commit is contained in:
commit
89d14ff29c
3 changed files with 71 additions and 1 deletions
|
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=getdns
|
||||
PKG_VERSION:=1.6.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
|
57
libs/getdns/patches/020-openssl-no-dynamic.patch
Normal file
57
libs/getdns/patches/020-openssl-no-dynamic.patch
Normal file
|
@ -0,0 +1,57 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -334,6 +334,9 @@ check_include_file(openssl/err.h HAVE_OPENSSL_ERR_H)
|
||||
check_include_file(openssl/rand.h HAVE_OPENSSL_RAND_H)
|
||||
check_include_file(openssl/conf.h HAVE_OPENSSL_CONF_H)
|
||||
check_include_file(openssl/engine.h HAVE_OPENSSL_ENGINE_H)
|
||||
+check_include_file(openssl/bn.h HAVE_OPENSSL_BN_H)
|
||||
+check_include_file(openssl/dsa.h HAVE_OPENSSL_DSA_H)
|
||||
+check_include_file(openssl/rsa.h HAVE_OPENSSL_RSA_H)
|
||||
|
||||
set(CMAKE_REQUIRED_LIBRARIES ${OPENSSL_LIBRARIES})
|
||||
check_function_exists(DSA_SIG_set0 HAVE_DSA_SIG_SET0)
|
||||
--- a/cmake/include/cmakeconfig.h.in
|
||||
+++ b/cmake/include/cmakeconfig.h.in
|
||||
@@ -58,6 +58,9 @@
|
||||
#cmakedefine HAVE_OPENSSL_RAND_H 1
|
||||
#cmakedefine HAVE_OPENSSL_CONF_H 1
|
||||
#cmakedefine HAVE_OPENSSL_ENGINE_H 1
|
||||
+#cmakedefine HAVE_OPENSSL_BN_H 1
|
||||
+#cmakedefine HAVE_OPENSSL_DSA_H 1
|
||||
+#cmakedefine HAVE_OPENSSL_RSA_H 1
|
||||
|
||||
#cmakedefine HAVE_DSA_SIG_SET0 1
|
||||
#cmakedefine HAVE_DSA_SET0_PQG 1
|
||||
--- a/src/openssl/keyraw-internal.c
|
||||
+++ b/src/openssl/keyraw-internal.c
|
||||
@@ -21,10 +21,10 @@
|
||||
#include <openssl/err.h>
|
||||
#include <openssl/md5.h>
|
||||
#ifdef HAVE_OPENSSL_CONF_H
|
||||
-# include <openssl/conf.h>
|
||||
+#include <openssl/conf.h>
|
||||
#endif
|
||||
#ifdef HAVE_OPENSSL_ENGINE_H
|
||||
-# include <openssl/engine.h>
|
||||
+#include <openssl/engine.h>
|
||||
#endif
|
||||
#ifdef HAVE_OPENSSL_BN_H
|
||||
#include <openssl/bn.h>
|
||||
@@ -35,6 +35,9 @@
|
||||
#ifdef HAVE_OPENSSL_DSA_H
|
||||
#include <openssl/dsa.h>
|
||||
#endif
|
||||
+#ifdef HAVE_OPENSSL_RSA_H
|
||||
+#include <openssl/rsa.h>
|
||||
+#endif
|
||||
#endif /* HAVE_SSL */
|
||||
|
||||
#ifdef HAVE_SSL
|
||||
@@ -74,7 +77,6 @@ gldns_key_EVP_load_gost_id(void)
|
||||
if(!e) {
|
||||
/* load it ourself, in case statically linked */
|
||||
ENGINE_load_builtin_engines();
|
||||
- ENGINE_load_dynamic();
|
||||
e = ENGINE_by_id("gost");
|
||||
}
|
||||
if(!e) {
|
13
libs/getdns/patches/030-typo-cmake-fix-stubby.patch
Normal file
13
libs/getdns/patches/030-typo-cmake-fix-stubby.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- a/cmake/include/cmakeconfig.h.in
|
||||
+++ b/cmake/include/cmakeconfig.h.in
|
||||
@@ -91,8 +91,8 @@
|
||||
#cmakedefine HAVE_OPENSSL_VERSION 1
|
||||
|
||||
#cmakedefine HAVE_SSL_CTX_DANE_ENABLE 1
|
||||
-#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITS 1
|
||||
-#cmakedefine HAVE_SSL_SET_CIPHERSUITS 1
|
||||
+#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITES 1
|
||||
+#cmakedefine HAVE_SSL_SET_CIPHERSUITES 1
|
||||
|
||||
#cmakedefine HAVE_OPENSSL_INIT_CRYPTO 1
|
||||
|
Loading…
Reference in a new issue