getdns: Fix TLS V1.3 Ciphersuites option in Stubby

Description :
Fix typo in CMAKE getdns included files, so Stubby can use TLS v1.3 with chipersuites options ON.

This solve issue that's written in here :
https://github.com/getdnsapi/stubby/issues/240
https://github.com/getdnsapi/stubby/issues/257

Signed-off-by: Harris K Kusuma <igharris.kk@gmail.com>
This commit is contained in:
Harris K Kusuma 2021-02-01 18:06:09 +07:00 committed by Jonathan G. Underwood
parent d7b42dcaa4
commit 1cec6bcfa1
2 changed files with 14 additions and 1 deletions

View file

@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=getdns
PKG_VERSION:=1.6.0
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE

View file

@ -0,0 +1,13 @@
--- a/cmake/include/cmakeconfig.h.in
+++ b/cmake/include/cmakeconfig.h.in
@@ -91,8 +91,8 @@
#cmakedefine HAVE_OPENSSL_VERSION 1
#cmakedefine HAVE_SSL_CTX_DANE_ENABLE 1
-#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITS 1
-#cmakedefine HAVE_SSL_SET_CIPHERSUITS 1
+#cmakedefine HAVE_SSL_CTX_SET_CIPHERSUITES 1
+#cmakedefine HAVE_SSL_SET_CIPHERSUITES 1
#cmakedefine HAVE_OPENSSL_INIT_CRYPTO 1