Merge pull request #11233 from neheb/hhg

zerotier: fix compilation with libcxx
This commit is contained in:
Rosen Penev 2020-02-04 03:01:52 -08:00 committed by GitHub
commit 6e6e076eef
No known key found for this signature in database
GPG key ID: 4AEE18F83AFDEB23
2 changed files with 11 additions and 1 deletions

View file

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zerotier PKG_NAME:=zerotier
PKG_VERSION:=1.4.6 PKG_VERSION:=1.4.6
PKG_RELEASE:=1 PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)? PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?

View file

@ -0,0 +1,10 @@
--- a/osdep/LinuxNetLink.hpp
+++ b/osdep/LinuxNetLink.hpp
@@ -18,6 +18,7 @@
#ifdef __LINUX__
+#include <cerrno>
#include <vector>
#include <sys/socket.h>