diff --git a/net/zerotier/Makefile b/net/zerotier/Makefile
index 4413da2df..14a9d6fe8 100644
--- a/net/zerotier/Makefile
+++ b/net/zerotier/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zerotier
 PKG_VERSION:=1.4.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/zerotier/ZeroTierOne/tar.gz/$(PKG_VERSION)?
diff --git a/net/zerotier/patches/010-mangix.patch b/net/zerotier/patches/010-mangix.patch
new file mode 100644
index 000000000..68e3bc572
--- /dev/null
+++ b/net/zerotier/patches/010-mangix.patch
@@ -0,0 +1,10 @@
+--- a/osdep/LinuxNetLink.hpp
++++ b/osdep/LinuxNetLink.hpp
+@@ -18,6 +18,7 @@
+ 
+ #ifdef __LINUX__
+ 
++#include <cerrno>
+ #include <vector>
+ 
+ #include <sys/socket.h>