Merge pull request #14362 from neheb/hwd
hwdata: introduce package and use
This commit is contained in:
commit
6b1f0439e8
7 changed files with 111 additions and 37 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=usbip
|
||||
PKG_RELEASE:=12
|
||||
PKG_RELEASE:=13
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
|
||||
# Since kernel 2.6.39.1 userspace tools are inside the kernel tree
|
||||
|
@ -52,7 +52,7 @@ endef
|
|||
define Package/usbip
|
||||
$(call Package/usbip/Default)
|
||||
TITLE+= (common)
|
||||
DEPENDS+= +libwrap +kmod-usbip +libudev +USE_GLIBC:libbsd
|
||||
DEPENDS+= +libwrap +kmod-usbip +libudev +USE_GLIBC:libbsd +usbids
|
||||
endef
|
||||
|
||||
define Package/usbip-client
|
||||
|
@ -80,20 +80,9 @@ endef
|
|||
CONFIGURE_VARS+= $(if $(CONFIG_USE_GLIBC),LIBS='-lbsd -lpthread')
|
||||
CFLAGS+="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include"
|
||||
|
||||
USB_IDS_VER:=0.318
|
||||
USB_IDS_FILE:=usb.ids.$(USB_IDS_VER)
|
||||
define Download/usb.ids
|
||||
FILE:=$(USB_IDS_FILE)
|
||||
URL_FILE:=usb.ids
|
||||
URL:=@GITHUB/vcrhonek/hwdata/v$(USB_IDS_VER)
|
||||
HASH:=84bc5452e4e45c2250e01bc74e03528b2a53c4724b2c4a5feaea76a922f83915
|
||||
endef
|
||||
|
||||
define Package/usbip/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbip.so.* $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/share/hwdata
|
||||
$(CP) $(DL_DIR)/usb.ids.$(USB_IDS_VER) $(1)/usr/share/hwdata/usb.ids
|
||||
endef
|
||||
|
||||
define Package/usbip-client/install
|
||||
|
@ -106,7 +95,6 @@ define Package/usbip-server/install
|
|||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/usbipd $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call Download,usb.ids))
|
||||
$(eval $(call BuildPackage,usbip))
|
||||
$(eval $(call BuildPackage,usbip-client))
|
||||
$(eval $(call BuildPackage,usbip-server))
|
||||
|
|
50
utils/hwdata/Makefile
Normal file
50
utils/hwdata/Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=hwdata
|
||||
PKG_VERSION:=0.342
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/vcrhonek/hwdata/tar.gz/v$(PKG_VERSION)?
|
||||
PKG_HASH:=f1e79131c870dce4a3b4b75edeefc5c9aef416d488a131c66cb6893be743be63
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-2.0-or-later XFree86-1.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/pciids
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=USB ID list
|
||||
URL:=https://github.com/vcrhonek/hwdata
|
||||
endef
|
||||
|
||||
define Package/usbids
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=PCI ID list
|
||||
URL:=https://github.com/vcrhonek/hwdata
|
||||
endef
|
||||
|
||||
define Package/pciids/install
|
||||
$(INSTALL_DIR) $(1)/usr/share/hwdata
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/hwdata/pci.ids $(1)/usr/share/hwdata
|
||||
endef
|
||||
|
||||
define Package/usbids/install
|
||||
$(INSTALL_DIR) $(1)/usr/share/hwdata
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/hwdata/usb.ids $(1)/usr/share/hwdata
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,pciids))
|
||||
$(eval $(call BuildPackage,usbids))
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=pciutils
|
||||
PKG_VERSION:=3.7.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
|
||||
|
@ -29,7 +29,7 @@ define Package/pciutils
|
|||
CATEGORY:=Utilities
|
||||
TITLE:=Linux PCI Utilities
|
||||
URL:=http://mj.ucw.cz/pciutils.shtml
|
||||
DEPENDS:=+libkmod +libpci
|
||||
DEPENDS:=+libkmod +libpci +pciids
|
||||
endef
|
||||
|
||||
define Package/pciutils/description
|
||||
|
@ -44,23 +44,6 @@ define Package/libpci
|
|||
URL:=http://mj.ucw.cz/pciutils.shtml
|
||||
endef
|
||||
|
||||
|
||||
PCI_IDS_VER:=0.336
|
||||
PCI_IDS_FILE:=pci.ids.$(PCI_IDS_VER)
|
||||
define Download/pci_ids
|
||||
FILE:=$(PCI_IDS_FILE)
|
||||
URL_FILE:=pci.ids
|
||||
URL:=@GITHUB/vcrhonek/hwdata/v$(PCI_IDS_VER)
|
||||
HASH:=94053616c1f9b93540861931fb7891b1b30d6fd21b3e2c1647467527ea38f557
|
||||
endef
|
||||
$(eval $(call Download,pci_ids))
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
$(RM) $(PKG_BUILD_DIR)/pci.ids
|
||||
$(CP) $(DL_DIR)/$(PCI_IDS_FILE) $(PKG_BUILD_DIR)/pci.ids
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
MAKE_FLAGS += \
|
||||
|
@ -92,8 +75,6 @@ endef
|
|||
define Package/pciutils/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{lspci,setpci,update-pciids} $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/usr/share
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/pci.ids $(1)/usr/share/
|
||||
endef
|
||||
|
||||
define Package/libpci/install
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -119,7 +119,7 @@
|
||||
@@ -119,7 +119,7 @@ distclean: clean
|
||||
install: all
|
||||
# -c is ignored on Linux, but required on FreeBSD
|
||||
$(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7 $(DESTDIR)/$(MANDIR)/man5
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- a/update-pciids.sh
|
||||
+++ b/update-pciids.sh
|
||||
@@ -6,9 +6,8 @@ set -e
|
||||
SRC="http://pci-ids.ucw.cz/v2.2/pci.ids"
|
||||
SRC="https://pci-ids.ucw.cz/v2.2/pci.ids"
|
||||
DEST=pci.ids
|
||||
PCI_COMPRESSED_IDS=
|
||||
-GREP=grep
|
||||
|
|
11
utils/pciutils/patches/106-hwdata.patch
Normal file
11
utils/pciutils/patches/106-hwdata.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -35,7 +35,7 @@ ABI_VERSION=.3
|
||||
PREFIX=/usr/local
|
||||
SBINDIR=$(PREFIX)/sbin
|
||||
SHAREDIR=$(PREFIX)/share
|
||||
-IDSDIR=$(SHAREDIR)
|
||||
+IDSDIR=$(SHAREDIR)/hwdata
|
||||
MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
|
||||
INCDIR=$(PREFIX)/include
|
||||
LIBDIR=$(PREFIX)/lib
|
44
utils/usbutils/Makefile
Normal file
44
utils/usbutils/Makefile
Normal file
|
@ -0,0 +1,44 @@
|
|||
#
|
||||
# Copyright (C) 2007-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=usbutils
|
||||
PKG_VERSION:=013
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/usb/usbutils
|
||||
PKG_HASH:=9e23494fcc78b7a80ee29a07dd179c95ae2f71509c35728dbbabc2d1cca41338
|
||||
|
||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||
PKG_LICENSE:=GPL-2.0-only
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/usbutils
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libusb-1.0 +libudev +usbids +librt +libpthread
|
||||
TITLE:=USB devices listing utilities
|
||||
URL:=http://www.linux-usb.org/
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--datadir=$(CONFIGURE_PREFIX)/share/hwdata
|
||||
|
||||
define Package/usbutils/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lsusb $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,usbutils))
|
Loading…
Reference in a new issue