pciutils: use new pciids package
Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
71cb006920
commit
8e8f6cb726
4 changed files with 15 additions and 23 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=pciutils
|
||||
PKG_VERSION:=3.7.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
|
||||
|
@ -29,7 +29,7 @@ define Package/pciutils
|
|||
CATEGORY:=Utilities
|
||||
TITLE:=Linux PCI Utilities
|
||||
URL:=http://mj.ucw.cz/pciutils.shtml
|
||||
DEPENDS:=+libkmod +libpci
|
||||
DEPENDS:=+libkmod +libpci +pciids
|
||||
endef
|
||||
|
||||
define Package/pciutils/description
|
||||
|
@ -44,23 +44,6 @@ define Package/libpci
|
|||
URL:=http://mj.ucw.cz/pciutils.shtml
|
||||
endef
|
||||
|
||||
|
||||
PCI_IDS_VER:=0.336
|
||||
PCI_IDS_FILE:=pci.ids.$(PCI_IDS_VER)
|
||||
define Download/pci_ids
|
||||
FILE:=$(PCI_IDS_FILE)
|
||||
URL_FILE:=pci.ids
|
||||
URL:=@GITHUB/vcrhonek/hwdata/v$(PCI_IDS_VER)
|
||||
HASH:=94053616c1f9b93540861931fb7891b1b30d6fd21b3e2c1647467527ea38f557
|
||||
endef
|
||||
$(eval $(call Download,pci_ids))
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
$(RM) $(PKG_BUILD_DIR)/pci.ids
|
||||
$(CP) $(DL_DIR)/$(PCI_IDS_FILE) $(PKG_BUILD_DIR)/pci.ids
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
MAKE_FLAGS += \
|
||||
|
@ -92,8 +75,6 @@ endef
|
|||
define Package/pciutils/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{lspci,setpci,update-pciids} $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/usr/share
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/pci.ids $(1)/usr/share/
|
||||
endef
|
||||
|
||||
define Package/libpci/install
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -119,7 +119,7 @@
|
||||
@@ -119,7 +119,7 @@ distclean: clean
|
||||
install: all
|
||||
# -c is ignored on Linux, but required on FreeBSD
|
||||
$(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7 $(DESTDIR)/$(MANDIR)/man5
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- a/update-pciids.sh
|
||||
+++ b/update-pciids.sh
|
||||
@@ -6,9 +6,8 @@ set -e
|
||||
SRC="http://pci-ids.ucw.cz/v2.2/pci.ids"
|
||||
SRC="https://pci-ids.ucw.cz/v2.2/pci.ids"
|
||||
DEST=pci.ids
|
||||
PCI_COMPRESSED_IDS=
|
||||
-GREP=grep
|
||||
|
|
11
utils/pciutils/patches/106-hwdata.patch
Normal file
11
utils/pciutils/patches/106-hwdata.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -35,7 +35,7 @@ ABI_VERSION=.3
|
||||
PREFIX=/usr/local
|
||||
SBINDIR=$(PREFIX)/sbin
|
||||
SHAREDIR=$(PREFIX)/share
|
||||
-IDSDIR=$(SHAREDIR)
|
||||
+IDSDIR=$(SHAREDIR)/hwdata
|
||||
MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
|
||||
INCDIR=$(PREFIX)/include
|
||||
LIBDIR=$(PREFIX)/lib
|
Loading…
Reference in a new issue