tcpreplay: upgrade to 4.1.2
Contains patch that fixes compat with musl:
7c942b71d4
Signed-off-by: Alexandru Ardelean <alexandru.ardelean@riverbed.com>
This commit is contained in:
parent
583af8565e
commit
612a0d5ebb
2 changed files with 3 additions and 34 deletions
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=tcpreplay
|
PKG_NAME:=tcpreplay
|
||||||
PKG_VERSION:=4.1.1
|
PKG_VERSION:=4.1.2
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/appneta/tcpreplay/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/appneta/tcpreplay/releases/download/v$(PKG_VERSION)
|
||||||
PKG_MD5SUM:=80394c33fe697b53b69eac9bb0968ae9
|
PKG_MD5SUM:=3105b10b07dbc0b07ce2da07a2368359
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-3.0
|
PKG_LICENSE:=GPL-3.0
|
||||||
PKG_LICENSE_FILES:=docs/LICENSE
|
PKG_LICENSE_FILES:=docs/LICENSE
|
||||||
|
|
|
@ -1,31 +0,0 @@
|
||||||
--- a/src/common/fakepoll.h
|
|
||||||
+++ b/src/common/fakepoll.h
|
|
||||||
@@ -40,11 +40,11 @@
|
|
||||||
#define POLL_NO_WARN
|
|
||||||
#define SYS_POLL_NO_WARN
|
|
||||||
|
|
||||||
-#ifdef HAVE_SYS_POLL_H
|
|
||||||
-#include <sys/poll.h>
|
|
||||||
-#define __FAKEPOLL_H
|
|
||||||
-#elif HAVE_POLL_H
|
|
||||||
+#ifdef HAVE_POLL_H
|
|
||||||
#include <poll.h>
|
|
||||||
+#define __FAKEPOLL_H
|
|
||||||
+#elif HAVE_SYS_POLL_H
|
|
||||||
+#include <sys/poll.h>
|
|
||||||
#define __FAKEPOLL_H
|
|
||||||
#endif
|
|
||||||
|
|
||||||
--- a/src/common/sendpacket.c
|
|
||||||
+++ b/src/common/sendpacket.c
|
|
||||||
@@ -148,10 +148,6 @@
|
|
||||||
#include "txring.h"
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#ifndef __GLIBC__
|
|
||||||
-typedef int socklen_t;
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
static sendpacket_t *sendpacket_open_pf(const char *, char *);
|
|
||||||
static struct tcpr_ether_addr *sendpacket_get_hwaddr_pf(sendpacket_t *);
|
|
||||||
static int get_iface_index(int fd, const char *device, char *);
|
|
Loading…
Reference in a new issue