gpgme: update to version 1.18.0

Noteworthy changes in version 1.17.0 (2022-02-07)
 -------------------------------------------------

 * New context flag "key-origin".  [#5733]
 * New context flag "import-filter".  [#5739]
 * New export mode to export secret subkeys.  [#5757]
 * Detect errors during the export of secret keys.  [#5766]
 * New function gpgme_op_receive_keys to import keys from a keyserver
   without first running a key listing.  [#5808]
 * Detect bad passphrase error in certificate import.  [T5713]
 * Allow setting --key-origin when importing keys.  [T5733]
 * Support components "keyboxd", "gpg-agent", "scdaemon", "dirmngr",
   "pinentry", and "socketdir" in gpgme_get_dirinfo.  [T5727,T5613]
 * Under Unix use poll(2) instead of select(2), when available.
   [T2385]
 * Do not use --flat_namespace when linking for macOS.  [T5610]
 * Fix results returned by gpgme_data_* functions.  [T5481]
 * Support closefrom also for glibc.  [rM4b64774b6d]
 * cpp,qt: Add support for export of secret keys and secret subkeys.
   [#5757]
 * cpp,qt: Support for adding existing subkeys to other keys.  [#5770]
 * qt: Extend ChangeExpiryJob to change expiration of primary key
   and of subkeys at the same time. [#4717]
 * qt: Expect UTF-8 on stderr on Windows.  [rM8fe1546282]
 * qt: Allow retrieving the default value of a config entry.  [T5515]

 Noteworthy changes in version 1.17.1 (2022-03-06)
 -------------------------------------------------

 * qt: Fix a bug in the ABI compatibility of 1.17.0.  [T5834]

 Noteworthy changes in version 1.18.0 (2022-08-10)
 -------------------------------------------------

 * New keylist mode to force refresh via external methods.  [T5951]
 * The keylist operations now create an import result to report the
   result of the locate keylist modes.  [T5951]
 * core: Return BAD_PASSPHRASE error code on symmetric decryption
   failure.  [T5939]
 * cpp, qt: Do not export internal symbols anymore.  [T5906]
 * cpp, qt: Support revocation of own OpenPGP keys.  [T5904]
 * qt: The file name of (signed and) encrypted data can now be set.  [T6056]
 * cpp, qt: Support setting the primary user ID.  [T5938]
 * python: Fix segv(NULL) when inspecting contect after exeception.  [T6060]

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit d7799595bd)
(cherry picked from commit 00bfb4f151)
This commit is contained in:
Daniel Golle 2022-03-24 22:30:03 +00:00
parent a471198392
commit 48f44bcc58
No known key found for this signature in database
GPG key ID: 5A8F39C31C3217CA
2 changed files with 3 additions and 30 deletions

View file

@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gpgme
PKG_VERSION:=1.16.0
PKG_RELEASE:=2
PKG_VERSION:=1.18.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://gnupg.org/ftp/gcrypt/$(PKG_NAME)
PKG_HASH:=6c8cc4aedb10d5d4c905894ba1d850544619ee765606ac43df7405865de29ed0
PKG_HASH:=361d4eae47ce925dba0ea569af40e7b52c645c4ae2e65e5621bf1b6cdd8b0e9e
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=GPL-3.0-or-later

View file

@ -1,27 +0,0 @@
From: Jiri Kucera <sanczes@gmail.com>
Date: Sun, 25 Jul 2021 09:35:54 +0000 (+0200)
Subject: core: Support closefrom also for glibc.
X-Git-Url: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=commitdiff_plain;h=4b64774b6d13ffa4f59dddf947a97d61bcfa2f2e
core: Support closefrom also for glibc.
* src/posix-io.c (_gpgme_io_spawn): Use glibc's closefrom.
--
Since 2.34, glibc introduces closefrom (the implementation
follows *BSD standard).
Signed-off-by: Werner Koch <wk@gnupg.org>
---
--- a/src/posix-io.c
+++ b/src/posix-io.c
@@ -570,7 +570,7 @@ _gpgme_io_spawn (const char *path, char
if (fd_list[i].fd > fd)
fd = fd_list[i].fd;
fd++;
-#if defined(__sun) || defined(__FreeBSD__)
+#if defined(__sun) || defined(__FreeBSD__) || defined(__GLIBC__)
closefrom (fd);
max_fds = fd;
#else /*!__sun */