gpgme: update to version 1.17.1
Remove backported patch which is now included in the upstream release. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
This commit is contained in:
parent
bed70d5f4b
commit
d7799595bd
2 changed files with 3 additions and 30 deletions
|
@ -1,12 +1,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gpgme
|
||||
PKG_VERSION:=1.16.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.17.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://gnupg.org/ftp/gcrypt/$(PKG_NAME)
|
||||
PKG_HASH:=6c8cc4aedb10d5d4c905894ba1d850544619ee765606ac43df7405865de29ed0
|
||||
PKG_HASH:=711eabf5dd661b9b04be9edc9ace2a7bc031f6bd9d37a768d02d0efdef108f5f
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
From: Jiri Kucera <sanczes@gmail.com>
|
||||
Date: Sun, 25 Jul 2021 09:35:54 +0000 (+0200)
|
||||
Subject: core: Support closefrom also for glibc.
|
||||
X-Git-Url: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gpgme.git;a=commitdiff_plain;h=4b64774b6d13ffa4f59dddf947a97d61bcfa2f2e
|
||||
|
||||
core: Support closefrom also for glibc.
|
||||
|
||||
* src/posix-io.c (_gpgme_io_spawn): Use glibc's closefrom.
|
||||
--
|
||||
|
||||
Since 2.34, glibc introduces closefrom (the implementation
|
||||
follows *BSD standard).
|
||||
|
||||
Signed-off-by: Werner Koch <wk@gnupg.org>
|
||||
---
|
||||
|
||||
--- a/src/posix-io.c
|
||||
+++ b/src/posix-io.c
|
||||
@@ -570,7 +570,7 @@ _gpgme_io_spawn (const char *path, char
|
||||
if (fd_list[i].fd > fd)
|
||||
fd = fd_list[i].fd;
|
||||
fd++;
|
||||
-#if defined(__sun) || defined(__FreeBSD__)
|
||||
+#if defined(__sun) || defined(__FreeBSD__) || defined(__GLIBC__)
|
||||
closefrom (fd);
|
||||
max_fds = fd;
|
||||
#else /*!__sun */
|
Loading…
Reference in a new issue