Merge pull request #4869 from apatrushev/master
micropython: updated to v1.9.2, micropython-lib: updated to v1.9
This commit is contained in:
commit
411b85b664
3 changed files with 21 additions and 9 deletions
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=micropython-lib
|
||||
PKG_VERSION=1.8.6-$(PKG_SOURCE_VERSION)
|
||||
PKG_VERSION=1.9-$(PKG_SOURCE_VERSION)
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
||||
|
@ -17,11 +17,11 @@ PKG_LICENSE_FILES:=LICENSE
|
|||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/micropython/micropython-lib.git
|
||||
PKG_SOURCE_VERSION:=f81e979c56dddb771ad36ec381b7f2c6cd12111f
|
||||
PKG_SOURCE_VERSION:=f5fe55aaef1a39d3d56f07040c0ff9f7e841fdf7
|
||||
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION)
|
||||
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
|
||||
PKG_MIRROR_HASH:=b9642fb3d01a7423d64ecc6ea81b4fac81a9112494727c8ca7744bd8e3ac120b
|
||||
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.xz
|
||||
PKG_MIRROR_HASH:=76565b5d44d47ccf61562f98dcf166d8103760eed7f3d84f5f7f31610140d780
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
|
|
|
@ -8,7 +8,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=micropython
|
||||
PKG_VERSION=1.8.6-$(PKG_SOURCE_VERSION)
|
||||
PKG_VERSION=1.9.2-$(PKG_SOURCE_VERSION)
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
|
||||
|
@ -17,11 +17,11 @@ PKG_LICENSE_FILES:=LICENSE
|
|||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=https://github.com/micropython/micropython.git
|
||||
PKG_SOURCE_VERSION:=5a1d63fc14dae788f705403a43c2d8639b7dd9cd
|
||||
PKG_SOURCE_VERSION:=1f78e7a43130acfa4bedf16c1007a1b0f37c75c3
|
||||
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
|
||||
PKG_MIRROR_HASH:=cd431a94664277ac3f80a25b3f6ebc415b281c9265faad154bd0b3fbe638167e
|
||||
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.xz
|
||||
PKG_MIRROR_HASH:=18234ffd1e91ac461080b4213399a6a18d4163fe314782b2e6ffbd1bfe48537b
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
|
@ -42,7 +42,7 @@ define Package/micropython/description
|
|||
endef
|
||||
|
||||
|
||||
MAKE_FLAGS += -C $(PKG_BUILD_DIR)/unix
|
||||
MAKE_FLAGS += -C $(PKG_BUILD_DIR)/unix FROZEN_MPY_DIR=
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,axtls)
|
||||
|
|
12
lang/python/micropython/patches/001-all-unix
Normal file
12
lang/python/micropython/patches/001-all-unix
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- a/py/persistentcode.c 2017-09-22 13:26:04.914339465 +0000
|
||||
+++ b/py/persistentcode.c 2017-09-22 13:26:22.618319621 +0000
|
||||
@@ -373,7 +373,7 @@
|
||||
|
||||
// here we define mp_raw_code_save_file depending on the port
|
||||
// TODO abstract this away properly
|
||||
|
||||
-#if defined(__i386__) || defined(__x86_64__) || (defined(__arm__) && (defined(__unix__)))
|
||||
+#if defined(__i386__) || defined(__x86_64__) || defined(__unix__)
|
||||
|
||||
#include <unistd.h>
|
||||
|
Loading…
Reference in a new issue