gst1-libav: Fix Makefile syntax error.
gstreamer1: Fix failures on buildbot mips platforms (accidently finds libunwind) Signed-off-by: Ted Hess <thess@kitschensync.net>
This commit is contained in:
parent
8dc8716e74
commit
901777195b
3 changed files with 25 additions and 0 deletions
|
@ -146,6 +146,7 @@ LIBAV_CONFIGURE_PROTOCOLS:=$(call FILTER_CONFIG,PROTOCOL,protocol,$(LIBAV_PROTOC
|
|||
|
||||
CONFIGURE_ARGS += \
|
||||
--without-system-libav \
|
||||
--with-libav-extra-configure=" \
|
||||
--disable-bsfs \
|
||||
--disable-programs \
|
||||
--disable-devices \
|
||||
|
|
|
@ -121,6 +121,7 @@ CONFIGURE_ARGS += \
|
|||
--disable-examples \
|
||||
--disable-tests \
|
||||
--disable-valgrind \
|
||||
--disable-gst-tracer-hooks \
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
--without-x \
|
||||
|
|
23
multimedia/gstreamer1/patches/004-no-unwind.patch
Normal file
23
multimedia/gstreamer1/patches/004-no-unwind.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -826,20 +826,6 @@ if test "x$BUILD_EXAMPLES" = "xyes"; the
|
||||
fi
|
||||
AM_CONDITIONAL(HAVE_GTK, test "x$HAVE_GTK" = "xyes")
|
||||
|
||||
-dnl libunwind is optionally used by the leaks tracer
|
||||
-PKG_CHECK_MODULES(UNWIND, libunwind, HAVE_UNWIND=yes, HAVE_UNWIND=no)
|
||||
-
|
||||
-dnl Check for backtrace() from libc
|
||||
-AC_CHECK_FUNC(backtrace, [
|
||||
- AC_CHECK_HEADERS([execinfo.h], [
|
||||
- AC_DEFINE(HAVE_BACKTRACE,1,[Have backtrace])
|
||||
- ], [], [])
|
||||
-])
|
||||
-
|
||||
-if test "x$HAVE_UNWIND" = "xyes"; then
|
||||
- AC_DEFINE(HAVE_UNWIND, 1, [libunwind available])
|
||||
-fi
|
||||
-
|
||||
dnl building of unit test libraries
|
||||
AC_ARG_ENABLE(check,
|
||||
AS_HELP_STRING([--disable-check],[disable building unit test libraries]),
|
Loading…
Reference in a new issue