muninlite: Enable the df plugin again and fix parsing disk usage
Closes: #1926 Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
This commit is contained in:
parent
e3b0a20c44
commit
4100e103fc
3 changed files with 11 additions and 13 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=muninlite
|
||||
PKG_VERSION:=1.0.4
|
||||
PKG_RELEASE:=6
|
||||
PKG_RELEASE:=7
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
|
|
10
admin/muninlite/patches/001-fix_disks.patch
Normal file
10
admin/muninlite/patches/001-fix_disks.patch
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- a/plugins/df 2015-11-07 17:05:46.000000000 +0100
|
||||
+++ b/plugins/df 2015-11-07 17:05:49.183925905 +0100
|
||||
@@ -19,6 +19,6 @@
|
||||
do
|
||||
PINFO=$(df -P $PART | tail -1);
|
||||
PNAME=$(echo $PINFO | cut -d\ -f1 | sed 's/[\/.-]/_/g')
|
||||
- echo "$PNAME.value" $(echo $PINFO | cut -f5 -d\ | sed -e 's/\%//g')
|
||||
+ echo "$PNAME.value" $(echo $PINFO | sed -e 's/\%//g' -e 's/ */ /g' | cut -f5 -d' ')
|
||||
done
|
||||
}
|
|
@ -1,12 +0,0 @@
|
|||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1,7 +1,7 @@
|
||||
|
||||
|
||||
-PLUGINS=df cpu if_ if_err_ load memory processes swap netstat uptime interrupts irqstats ntpdate plugindir_
|
||||
-#PLUGINS=cpu if_ if_err_ load memory processes netstat uptime interrupts irqstats
|
||||
+#PLUGINS=df cpu if_ if_err_ load memory processes swap netstat uptime interrupts irqstats ntpdate plugindir_
|
||||
+PLUGINS=cpu if_ if_err_ load memory processes netstat uptime interrupts irqstats
|
||||
|
||||
munin-node: plugins/* munin-node.conf
|
||||
@VERSION=$$(cat VERSION); \
|
Loading…
Reference in a new issue