lcd4linux: fix endian issues with GLCD2USB plugin
Patch submitted by Vladimir Ermakov. Signed-off-by: Vladimir Ermakov <vooon341@gmail.com> Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com>
This commit is contained in:
parent
25c6b0818f
commit
e3b0a20c44
2 changed files with 21 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=lcd4linux
|
||||
PKG_REV:=1203
|
||||
PKG_VERSION:=r$(PKG_REV)
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://ssl.bulix.org/svn/lcd4linux/trunk/
|
||||
|
|
20
utils/lcd4linux/patches/173-glcd2usb-bigendian-fix.patch
Normal file
20
utils/lcd4linux/patches/173-glcd2usb-bigendian-fix.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- a/drv_GLCD2USB.c
|
||||
+++ b/drv_GLCD2USB.c
|
||||
@@ -48,6 +48,7 @@
|
||||
#include <fcntl.h>
|
||||
#include <sys/time.h>
|
||||
#include <usb.h>
|
||||
+#include <endian.h>
|
||||
|
||||
#include "debug.h"
|
||||
#include "cfg.h"
|
||||
@@ -487,6 +488,9 @@ static int drv_GLCD2USB_start(const char
|
||||
return -1;
|
||||
}
|
||||
|
||||
+ buffer.display_info.width = le16toh(buffer.display_info.width);
|
||||
+ buffer.display_info.height = le16toh(buffer.display_info.height);
|
||||
+
|
||||
info("%s: display name = %s", Name, buffer.display_info.name);
|
||||
info("%s: display resolution = %d * %d", Name, buffer.display_info.width, buffer.display_info.height);
|
||||
info("%s: display flags: %x", Name, buffer.display_info.flags);
|
Loading…
Reference in a new issue