commit
2b44a18df1
3 changed files with 14 additions and 13 deletions
|
@ -9,16 +9,17 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=poco
|
PKG_NAME:=poco
|
||||||
PKG_VERSION:=1.8.1
|
PKG_VERSION:=1.9.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_HASH:=2e4c07ac73174ee06c7e2c7cf2b7642a5b3aea81d0203e1c069b32ac4a8ecfbc
|
PKG_HASH:=a0a5a03d87c585f1a43def33bfc52c0c34a528e43a7b13bc83841a7c00adde39
|
||||||
|
|
||||||
PKG_LICENSE:=BSL-1.0
|
PKG_LICENSE:=BSL-1.0
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
@ -27,7 +28,7 @@ define Package/poco
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=Poco C++ libraries
|
TITLE:=Poco C++ libraries
|
||||||
URL:=http://www.pocoproject.org/
|
URL:=https://www.pocoproject.org/
|
||||||
DEPENDS:=+libstdcpp +libpthread +librt
|
DEPENDS:=+libstdcpp +libpthread +librt
|
||||||
MAINTAINER:=Jean-Michel Julien <jean-michel.julien@trilliantinc.com>
|
MAINTAINER:=Jean-Michel Julien <jean-michel.julien@trilliantinc.com>
|
||||||
endef
|
endef
|
||||||
|
|
|
@ -1,15 +1,15 @@
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -231,9 +231,9 @@
|
@@ -237,9 +237,9 @@ while [ $# -ge 1 ]; do
|
||||||
;;
|
;;
|
||||||
|
|
||||||
*)
|
*)
|
||||||
- showhelp
|
- showhelp
|
||||||
- exit 1
|
- exit 1
|
||||||
- ;;
|
- ;;
|
||||||
+# showhelp
|
+# showhelp
|
||||||
+# exit 1
|
+# exit 1
|
||||||
+# ;;
|
+# ;;
|
||||||
esac
|
esac
|
||||||
|
|
||||||
shift
|
shift
|
||||||
|
|
|
@ -2,7 +2,7 @@
|
||||||
+++ b/Foundation/src/Error.cpp
|
+++ b/Foundation/src/Error.cpp
|
||||||
@@ -70,7 +70,7 @@ namespace Poco {
|
@@ -70,7 +70,7 @@ namespace Poco {
|
||||||
|
|
||||||
#if (_XOPEN_SOURCE >= 600) || POCO_ANDROID || __APPLE__
|
#if (_XOPEN_SOURCE >= 600) || POCO_OS == POCO_OS_ANDROID || __APPLE__
|
||||||
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
|
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
|
||||||
-#elif _GNU_SOURCE
|
-#elif _GNU_SOURCE
|
||||||
+#elif (_GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__))
|
+#elif (_GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__))
|
||||||
|
|
Loading…
Reference in a new issue