poco: Update to 1.9.0
Some minor adjustments. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
ecd3dc4d7f
commit
05d11f13c3
3 changed files with 14 additions and 13 deletions
|
@ -9,16 +9,17 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=poco
|
||||
PKG_VERSION:=1.8.1
|
||||
PKG_VERSION:=1.9.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_HASH:=2e4c07ac73174ee06c7e2c7cf2b7642a5b3aea81d0203e1c069b32ac4a8ecfbc
|
||||
PKG_SOURCE_URL:=https://pocoproject.org/releases/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_HASH:=a0a5a03d87c585f1a43def33bfc52c0c34a528e43a7b13bc83841a7c00adde39
|
||||
|
||||
PKG_LICENSE:=BSL-1.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
@ -27,7 +28,7 @@ define Package/poco
|
|||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Poco C++ libraries
|
||||
URL:=http://www.pocoproject.org/
|
||||
URL:=https://www.pocoproject.org/
|
||||
DEPENDS:=+libstdcpp +libpthread +librt
|
||||
MAINTAINER:=Jean-Michel Julien <jean-michel.julien@trilliantinc.com>
|
||||
endef
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -231,9 +231,9 @@
|
||||
;;
|
||||
|
||||
*)
|
||||
@@ -237,9 +237,9 @@ while [ $# -ge 1 ]; do
|
||||
;;
|
||||
|
||||
*)
|
||||
- showhelp
|
||||
- exit 1
|
||||
- ;;
|
||||
+# showhelp
|
||||
+# exit 1
|
||||
+# ;;
|
||||
esac
|
||||
|
||||
shift
|
||||
esac
|
||||
|
||||
shift
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- a/Foundation/src/Error.cpp
|
||||
+++ b/Foundation/src/Error.cpp
|
||||
@@ -70,7 +70,7 @@ namespace Poco {
|
||||
|
||||
#if (_XOPEN_SOURCE >= 600) || POCO_ANDROID || __APPLE__
|
||||
|
||||
#if (_XOPEN_SOURCE >= 600) || POCO_OS == POCO_OS_ANDROID || __APPLE__
|
||||
setMessage(strerror_r(err, _buffer, sizeof(_buffer)));
|
||||
-#elif _GNU_SOURCE
|
||||
+#elif (_GNU_SOURCE && (defined __GLIBC__ || defined __UCLIBC__))
|
||||
|
|
Loading…
Reference in a new issue