Merge pull request #11133 from micmac1/apache2-cleanup
apache: cleanup, enable LFS and rename server from httpd to apache2
This commit is contained in:
commit
1631e5ae37
11 changed files with 156 additions and 175 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=apr-util
|
||||
PKG_VERSION:=1.6.1
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@APACHE/apr/
|
||||
|
@ -127,30 +127,26 @@ $$(eval $$(call BuildPackage,libaprutil-$(subst _,-,$(1))))
|
|||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1/ $(1)/usr/lib $(1)/usr/lib/pkgconfig/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-1-config \
|
||||
$(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
|
||||
$(1)/usr/include/apr-1/
|
||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1 \
|
||||
$(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-1-config $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-1/* $(1)/usr/include/apr-1
|
||||
ifneq ($(CONFIG_PACKAGE_libaprutil-crypto-openssl)$(CONFIG_PACKAGE_libaprutil-dbd-pgsql)$(CONFIG_PACKAGE_libaprutil-dbd-sqlite3)$(CONFIG_PACKAGE_libaprutil-ldap),)
|
||||
$(INSTALL_DIR) $(1)/usr/lib/apr-util-1
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/apr-util-1/apr_*{la,a,so*} \
|
||||
$(1)/usr/lib/apr-util-1
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/apr-util-1/apr_*{la,a,so*} \
|
||||
$(1)/usr/lib/apr-util-1
|
||||
endif
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{la,a,so*} \
|
||||
$(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
|
||||
$(1)/usr/lib/pkgconfig/
|
||||
$(SED) 's, -e \"s -I$$$$prefix/lib g\",,g' $(1)/usr/bin/apu-1-config
|
||||
$(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/apu-1-config
|
||||
$(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/apu-1-config
|
||||
$(SED) 's,-L$$$$libdir,,g' $(1)/usr/bin/apu-1-config
|
||||
$(SED) 's,-R$$$$libdir,,g' $(1)/usr/bin/apu-1-config
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.{la,a,so*} \
|
||||
$(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
|
||||
$(1)/usr/lib/pkgconfig
|
||||
$(SED) '/^prefix=\|^exec_prefix=/s|/usr|$(STAGING_DIR)/usr|' \
|
||||
$(1)/usr/bin/apu-1-config
|
||||
endef
|
||||
|
||||
define Package/libaprutil/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.so.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libaprutil-1.so.* $(1)/usr/lib
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libaprutil))
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -8,6 +8,7 @@ APRUTIL_MAJOR_VERSION=@APRUTIL_MAJOR_VER
|
||||
APRUTIL_DOTTED_VERSION=@APRUTIL_DOTTED_VERSION@
|
||||
|
||||
srcdir = @srcdir@
|
||||
+top_builddir = @top_builddir@
|
||||
VPATH = @srcdir@
|
||||
|
||||
INCLUDES = @APRUTIL_PRIV_INCLUDES@ @APR_INCLUDES@ @APRUTIL_INCLUDES@
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -41,6 +41,8 @@ AC_SUBST(APU_CONFIG_LOCATION)
|
||||
AC_CANONICAL_SYSTEM
|
||||
|
||||
AC_PROG_INSTALL
|
||||
+AC_PROG_LIBTOOL
|
||||
+LT_INIT
|
||||
|
||||
# Use -no-install or -no-fast-install to link the test
|
||||
# programs on all platforms but Darwin, where it would cause
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=apr
|
||||
PKG_VERSION:=1.6.5
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@APACHE/apr/
|
||||
|
@ -17,7 +17,11 @@ PKG_HASH:=a67ca9fcf9c4ff59bce7f428a323c8b5e18667fdea7b0ebad47d194371b0a105
|
|||
|
||||
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>, \
|
||||
Sebastian Kemper <sebastian_ml@gmx.net>
|
||||
|
||||
PKG_LICENSE:=Apache-2.0
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
|
||||
PKG_CPE_ID:=cpe:/a:apache:apr
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
|
@ -41,44 +45,45 @@ CONFIGURE_ARGS += \
|
|||
|
||||
# XXX: ac_cv_sizeof_struct_iovec=1 is just to trick configure
|
||||
CONFIGURE_VARS += \
|
||||
ac_cv_file__dev_zero=yes \
|
||||
ac_cv_func_pthread_mutexattr_setpshared=yes \
|
||||
ac_cv_func_sem_open=yes \
|
||||
ac_cv_func_setpgrp_void=yes \
|
||||
ac_cv_o_nonblock_inherited=no \
|
||||
ac_cv_sizeof_struct_iovec=1 \
|
||||
ac_cv_struct_rlimit=yes \
|
||||
ac_cv_func_sem_open=yes \
|
||||
ac_cv_func_pthread_mutexattr_setpshared=yes \
|
||||
apr_cv_mutex_robust_shared=yes \
|
||||
apr_cv_tcp_nodelay_with_cork=yes \
|
||||
apr_cv_sock_cloexec=yes \
|
||||
apr_cv_process_shared_works=yes \
|
||||
apr_cv_mutex_recursive=yes \
|
||||
apr_cv_epoll_create1=yes \
|
||||
apr_cv_epoll=yes \
|
||||
apr_cv_accept4=yes \
|
||||
apr_cv_dup3=yes \
|
||||
apr_cv_accept4=yes
|
||||
apr_cv_epoll=yes \
|
||||
apr_cv_epoll_create1=yes \
|
||||
apr_cv_mutex_recursive=yes \
|
||||
apr_cv_mutex_robust_shared=yes \
|
||||
apr_cv_process_shared_works=yes \
|
||||
apr_cv_sock_cloexec=yes \
|
||||
apr_cv_tcp_nodelay_with_cork=yes \
|
||||
apr_cv_use_lfs64=yes
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1 $(1)/usr/lib $(1)/usr/lib/pkgconfig $(1)/usr/share/build-1
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apr-1-config \
|
||||
$(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
|
||||
$(1)/usr/include/apr-1/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libapr-1.{la,a,so*} \
|
||||
$(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-1.pc \
|
||||
$(1)/usr/lib/pkgconfig/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/build-1/* \
|
||||
$(1)/usr/share/build-1/
|
||||
$(SED) 's,^datadir=\"/usr/share\",datadir=\"$(STAGING_DIR)/usr/share\",g' $(1)/usr/bin/apr-1-config
|
||||
$(SED) 's,^installbuilddir=\"/usr/share/build-1\",installbuilddir=\"$(STAGING_DIR)/usr/share/build-1\",g' $(1)/usr/bin/apr-1-config
|
||||
$(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/apr-1-config
|
||||
$(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/apr-1-config
|
||||
$(SED) 's,-L$$$$libdir,,g' $(1)/usr/bin/apr-1-config
|
||||
$(SED) 's,-R$$$$libdir,,g' $(1)/usr/bin/apr-1-config
|
||||
$(SED) 's,/usr/share/build-1,$(STAGING_DIR)/usr/share/build-1,g' $(1)/usr/share/build-1/apr_rules.mk
|
||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/include/apr-1 \
|
||||
$(1)/usr/lib/pkgconfig $(1)/usr/share/build-1
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/apr-1-config \
|
||||
$(1)/usr/bin
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
|
||||
$(1)/usr/include/apr-1
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libapr-1.{la,a,so*} $(1)/usr/lib
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-1.pc \
|
||||
$(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/build-1/* $(1)/usr/share/build-1
|
||||
$(SED) '/^prefix=\|^exec_prefix=/s|/usr|$(STAGING_DIR)/usr|' \
|
||||
$(1)/usr/bin/apr-1-config
|
||||
$(SED) '/^datadir=/s|/usr|$$$${prefix}|' $(1)/usr/bin/apr-1-config
|
||||
$(SED) 's,/usr/share/build-1,$(STAGING_DIR)/usr/share/build-1,g' \
|
||||
$(1)/usr/share/build-1/apr_rules.mk
|
||||
endef
|
||||
|
||||
define Package/libapr/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libapr-1.so.* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libapr-1.so.* $(1)/usr/lib
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libapr))
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
Index: apr-1.5.2/Makefile.in
|
||||
===================================================================
|
||||
--- apr-1.5.2.orig/Makefile.in
|
||||
+++ apr-1.5.2/Makefile.in
|
||||
@@ -3,6 +3,7 @@ srcdir=@srcdir@
|
||||
VPATH=@srcdir@
|
||||
top_srcdir=@apr_srcdir@
|
||||
top_blddir=@apr_builddir@
|
||||
+top_builddir=@top_builddir@
|
||||
|
||||
#
|
||||
# APR (Apache Portable Runtime) library Makefile.
|
||||
Index: apr-1.5.2/configure.in
|
||||
===================================================================
|
||||
--- apr-1.5.2.orig/configure.in
|
||||
+++ apr-1.5.2/configure.in
|
||||
@@ -245,9 +245,6 @@ case $host in
|
||||
gcc $CFLAGS $CPPFLAGS -o $LIBTOOL.exe $LIBTOOL.c
|
||||
;;
|
||||
*)
|
||||
- if test "x$LTFLAGS" = "x"; then
|
||||
- LTFLAGS='--silent'
|
||||
- fi
|
||||
if test "$experimental_libtool" = "yes"; then
|
||||
# Use a custom-made libtool replacement
|
||||
echo "using jlibtool"
|
56
libs/apr/patches/001-cross-compile.patch
Normal file
56
libs/apr/patches/001-cross-compile.patch
Normal file
|
@ -0,0 +1,56 @@
|
|||
Fix cross-compilation
|
||||
|
||||
Patch was backported from Apache httpd:
|
||||
http://svn.apache.org/viewvc?view=revision&revision=1327907
|
||||
http://svn.apache.org/viewvc?view=revision&revision=1328390
|
||||
http://svn.apache.org/viewvc?view=revision&revision=1328714
|
||||
|
||||
Patch submitted upstream:
|
||||
https://issues.apache.org/bugzilla/show_bug.cgi?id=57058
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -118,6 +118,16 @@ AC_CANONICAL_SYSTEM
|
||||
echo "Configuring APR library"
|
||||
echo "Platform: $host"
|
||||
|
||||
+dnl In case of cross compilation we set CC_FOR_BUILD to cc unless
|
||||
+dnl we got already CC_FOR_BUILD from environment.
|
||||
+if test "x${build_alias}" != "x${host_alias}"; then
|
||||
+ if test "x${CC_FOR_BUILD}" = "x"; then
|
||||
+ CC_FOR_BUILD=cc
|
||||
+ fi
|
||||
+fi
|
||||
+AC_SUBST(CC_FOR_BUILD)
|
||||
+AC_SUBST(CFLAGS_FOR_BUILD)
|
||||
+
|
||||
dnl Some initial steps for configuration. We setup the default directory
|
||||
dnl and which files are to be configured.
|
||||
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -8,6 +8,8 @@ top_blddir=@apr_builddir@
|
||||
# APR (Apache Portable Runtime) library Makefile.
|
||||
#
|
||||
CPP = @CPP@
|
||||
+CC_FOR_BUILD = @CC_FOR_BUILD@
|
||||
+CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
|
||||
|
||||
# get substituted into some targets
|
||||
APR_MAJOR_VERSION=@APR_MAJOR_VERSION@
|
||||
@@ -137,8 +139,13 @@ tools/gen_test_char.lo: tools/gen_test_c
|
||||
$(APR_MKDIR) tools
|
||||
$(LT_COMPILE)
|
||||
|
||||
+ifdef CC_FOR_BUILD
|
||||
+tools/gen_test_char@EXEEXT@: tools/gen_test_char.c $(LOCAL_LIBS)
|
||||
+ $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) -DCROSS_COMPILE -o $@ $<
|
||||
+else
|
||||
tools/gen_test_char@EXEEXT@: $(OBJECTS_gen_test_char)
|
||||
$(LINK_PROG) $(OBJECTS_gen_test_char) $(ALL_LIBS)
|
||||
+endif
|
||||
|
||||
include/private/apr_escape_test_char.h: tools/gen_test_char@EXEEXT@
|
||||
$(APR_MKDIR) include/private
|
37
libs/apr/patches/002-sys-param-h.patch
Normal file
37
libs/apr/patches/002-sys-param-h.patch
Normal file
|
@ -0,0 +1,37 @@
|
|||
Fix PATH_MAX detection by including sys/param.h if available
|
||||
|
||||
Patch sent upstream:
|
||||
https://bz.apache.org/bugzilla/show_bug.cgi?id=63782
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -1593,6 +1593,7 @@ AC_SUBST(stdlibh)
|
||||
AC_SUBST(stringh)
|
||||
AC_SUBST(stringsh)
|
||||
AC_SUBST(sys_ioctlh)
|
||||
+AC_SUBST(sys_paramh)
|
||||
AC_SUBST(sys_sendfileh)
|
||||
AC_SUBST(sys_signalh)
|
||||
AC_SUBST(sys_socketh)
|
||||
--- a/include/apr.h.in
|
||||
+++ b/include/apr.h.in
|
||||
@@ -94,6 +94,7 @@
|
||||
#define APR_HAVE_STRING_H @stringh@
|
||||
#define APR_HAVE_STRINGS_H @stringsh@
|
||||
#define APR_HAVE_SYS_IOCTL_H @sys_ioctlh@
|
||||
+#define APR_HAVE_SYS_PARAM_H @sys_paramh@
|
||||
#define APR_HAVE_SYS_SENDFILE_H @sys_sendfileh@
|
||||
#define APR_HAVE_SYS_SIGNAL_H @sys_signalh@
|
||||
#define APR_HAVE_SYS_SOCKET_H @sys_socketh@
|
||||
@@ -201,6 +202,9 @@
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
#endif
|
||||
+#if APR_HAVE_SYS_PARAM_H
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
|
||||
/**
|
||||
* @addtogroup apr_platform
|
|
@ -1,13 +0,0 @@
|
|||
https://dev.openwrt.org/ticket/9287
|
||||
|
||||
--- a/time/unix/time.c
|
||||
+++ b/time/unix/time.c
|
||||
@@ -75,7 +75,7 @@ APR_DECLARE(apr_time_t) apr_time_now(voi
|
||||
{
|
||||
struct timeval tv;
|
||||
gettimeofday(&tv, NULL);
|
||||
- return tv.tv_sec * APR_USEC_PER_SEC + tv.tv_usec;
|
||||
+ return tv.tv_sec * (apr_time_t)APR_USEC_PER_SEC + (apr_time_t)tv.tv_usec;
|
||||
}
|
||||
|
||||
static void explode_time(apr_time_exp_t *xt, apr_time_t t,
|
|
@ -1,51 +0,0 @@
|
|||
Makefile.in: fix cross compiling failed
|
||||
|
||||
The tools/gen_test_char was invoked at build time,
|
||||
and it didn't work for the cross compiling, so we
|
||||
compile it with $BUILDCC.
|
||||
|
||||
Remove the 'tools' dir creation, it always existed.
|
||||
And it caused gen_test_char unexpected rebuilt at
|
||||
do_install time.
|
||||
|
||||
Upstream-Status: inappropriate [oe specific]
|
||||
|
||||
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
|
||||
---
|
||||
Makefile.in | 10 ++--------
|
||||
1 file changed, 2 insertions(+), 8 deletions(-)
|
||||
|
||||
Index: apr-1.5.2/Makefile.in
|
||||
===================================================================
|
||||
--- apr-1.5.2.orig/Makefile.in
|
||||
+++ apr-1.5.2/Makefile.in
|
||||
@@ -20,7 +20,7 @@ INCDIR=./include
|
||||
OSDIR=$(top_srcdir)/include/arch/@OSDIR@
|
||||
DEFOSDIR=$(INCDIR)/arch/@DEFAULT_OSDIR@
|
||||
INCLUDES=-I$(INCDIR) -I$(OSDIR) -I$(DEFOSDIR) -I$(top_srcdir)/include/arch/@DEFAULT_OSDIR@ -I$(top_srcdir)/include -I$(top_srcdir)/include/private -I$(top_blddir)/include/private
|
||||
-
|
||||
+BUILDCC=gcc
|
||||
#
|
||||
# Macros for target determination
|
||||
#
|
||||
@@ -47,7 +47,6 @@ LT_VERSION = @LT_VERSION@
|
||||
|
||||
CLEAN_TARGETS = apr-config.out apr.exp exports.c export_vars.c .make.dirs \
|
||||
build/apr_rules.out tools/gen_test_char@EXEEXT@ \
|
||||
- tools/gen_test_char.o tools/gen_test_char.lo \
|
||||
include/private/apr_escape_test_char.h
|
||||
DISTCLEAN_TARGETS = config.cache config.log config.status \
|
||||
include/apr.h include/arch/unix/apr_private.h \
|
||||
@@ -138,9 +137,9 @@ tools/gen_test_char.lo: tools/gen_test_c
|
||||
$(APR_MKDIR) tools
|
||||
$(LT_COMPILE)
|
||||
|
||||
-tools/gen_test_char@EXEEXT@: $(OBJECTS_gen_test_char)
|
||||
- $(LINK_PROG) $(OBJECTS_gen_test_char) $(ALL_LIBS)
|
||||
-
|
||||
+tools/gen_test_char@EXEEXT@: tools/gen_test_char.c
|
||||
+ $(BUILDCC) $(CFLAGS_FOR_BUILD) $< -o $@
|
||||
+
|
||||
include/private/apr_escape_test_char.h: tools/gen_test_char@EXEEXT@
|
||||
$(APR_MKDIR) include/private
|
||||
tools/gen_test_char@EXEEXT@ > $@
|
|
@ -33,11 +33,9 @@ Upstream-Status: Pending
|
|||
configure.in | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 3b10422..a227e72 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -1771,7 +1771,7 @@ else
|
||||
@@ -1785,7 +1785,7 @@ else
|
||||
socklen_t_value="int"
|
||||
fi
|
||||
|
||||
|
@ -46,7 +44,7 @@ index 3b10422..a227e72 100644
|
|||
|
||||
if test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_short"; then
|
||||
pid_t_fmt='#define APR_PID_T_FMT "hd"'
|
||||
@@ -1840,7 +1840,7 @@ APR_CHECK_TYPES_COMPATIBLE(ssize_t, long, [ssize_t_fmt="ld"])
|
||||
@@ -1854,7 +1854,7 @@ APR_CHECK_TYPES_COMPATIBLE(ssize_t, long
|
||||
APR_CHECK_TYPES_COMPATIBLE(size_t, unsigned int, [size_t_fmt="u"])
|
||||
APR_CHECK_TYPES_COMPATIBLE(size_t, unsigned long, [size_t_fmt="lu"])
|
||||
|
||||
|
@ -55,7 +53,7 @@ index 3b10422..a227e72 100644
|
|||
|
||||
AC_MSG_CHECKING([which format to use for apr_ssize_t])
|
||||
if test -n "$ssize_t_fmt"; then
|
||||
@@ -1857,7 +1857,7 @@ fi
|
||||
@@ -1871,7 +1871,7 @@ fi
|
||||
|
||||
ssize_t_fmt="#define APR_SSIZE_T_FMT \"$ssize_t_fmt\""
|
||||
|
||||
|
@ -64,7 +62,7 @@ index 3b10422..a227e72 100644
|
|||
|
||||
AC_MSG_CHECKING([which format to use for apr_size_t])
|
||||
if test -n "$size_t_fmt"; then
|
||||
@@ -1874,7 +1874,7 @@ fi
|
||||
@@ -1888,7 +1888,7 @@ fi
|
||||
|
||||
size_t_fmt="#define APR_SIZE_T_FMT \"$size_t_fmt\""
|
||||
|
||||
|
@ -73,6 +71,3 @@ index 3b10422..a227e72 100644
|
|||
|
||||
if test "${ac_cv_sizeof_off_t}${apr_cv_use_lfs64}" = "4yes"; then
|
||||
# Enable LFS
|
||||
--
|
||||
1.8.3.1
|
||||
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=apache
|
||||
PKG_VERSION:=2.4.41
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
PKG_SOURCE_NAME:=httpd
|
||||
|
||||
PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
|
||||
|
@ -78,7 +78,7 @@ This package contains the Apache web server and utility programs.
|
|||
endef
|
||||
|
||||
define Package/apache/conffiles
|
||||
/etc/apache2/httpd.conf
|
||||
/etc/apache2/apache2.conf
|
||||
/etc/apache2/extra/httpd-autoindex.conf
|
||||
/etc/apache2/extra/httpd-dav.conf
|
||||
/etc/apache2/extra/httpd-default.conf
|
||||
|
@ -93,7 +93,7 @@ define Package/apache/conffiles
|
|||
/etc/apache2/extra/proxy-html.conf
|
||||
/etc/apache2/magic
|
||||
/etc/apache2/mime.types
|
||||
/etc/init.d/apache
|
||||
/etc/init.d/apache2
|
||||
endef
|
||||
|
||||
define Package/apache-ab
|
||||
|
@ -198,6 +198,7 @@ CONFIGURE_ARGS+= \
|
|||
--with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
|
||||
--with-mpm=prefork \
|
||||
--with-pcre="$(STAGING_DIR)/usr/bin/pcre-config" \
|
||||
--with-program-name=apache2 \
|
||||
--with-ssl
|
||||
|
||||
ifneq ($(CONFIG_PACKAGE_apache-mod-deflate),)
|
||||
|
@ -296,11 +297,13 @@ define Package/apache/install
|
|||
$(INSTALL_DIR) $(1)/etc/apache2/extra
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/apache2/extra/* \
|
||||
$(1)/etc/apache2/extra
|
||||
$(SED) '/^LoadModule session_crypto_module/s/^/#/' \
|
||||
$(PKG_INSTALL_DIR)/etc/apache2/apache2.conf
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/etc/apache2/{httpd.conf,magic,mime.types} \
|
||||
$(1)/etc/apache2
|
||||
$(PKG_INSTALL_DIR)/etc/apache2/{apache2.conf,magic,mime.types} \
|
||||
$(1)/etc/apache2
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/apache.init $(1)/etc/init.d/apache
|
||||
$(INSTALL_BIN) ./files/apache2.init $(1)/etc/init.d/apache2
|
||||
$(INSTALL_DIR) $(1)/usr/lib/apache2
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/apache2/*.so \
|
||||
$(1)/usr/lib/apache2
|
||||
|
@ -316,7 +319,7 @@ define Package/apache/install
|
|||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/{dbmmanage,htdbm,htdigest,htpasswd,httxt2dbm,logresolve} \
|
||||
$(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{apachectl,httpd} \
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{apachectl,apache2} \
|
||||
$(1)/usr/sbin
|
||||
endef
|
||||
|
||||
|
|
Loading…
Reference in a new issue