commit
e52d2fa663
3 changed files with 2 additions and 25 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nsd
|
||||
PKG_VERSION:=4.2.1
|
||||
PKG_VERSION:=4.2.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.nlnetlabs.nl/downloads/nsd
|
||||
PKG_HASH:=d17c0ea3968cb0eb2be79f2f83eb299b7bfcc554b784007616eed6ece828871f
|
||||
PKG_HASH:=9ebd6d766765631a56c0eb332eac26b310fa39f662e5582c8210488cf91ef27c
|
||||
|
||||
PKG_MAINTAINER:=Vasilis Tsiligiannis <acinonyx@openwrt.gr>
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- a/nsd-control.c
|
||||
+++ b/nsd-control.c
|
||||
@@ -42,6 +42,7 @@
|
||||
*/
|
||||
|
||||
#include "config.h"
|
||||
+#include <stdio.h>
|
||||
#ifdef HAVE_SSL
|
||||
|
||||
#include <sys/types.h>
|
|
@ -1,13 +0,0 @@
|
|||
--- a/tsig.c
|
||||
+++ b/tsig.c
|
||||
@@ -19,6 +19,10 @@
|
||||
#include "query.h"
|
||||
#include "rbtree.h"
|
||||
|
||||
+#ifndef HAVE_SSL
|
||||
+#define CRYPTO_memcmp memcmp
|
||||
+#endif
|
||||
+
|
||||
static region_type *tsig_region;
|
||||
|
||||
struct tsig_key_table
|
Loading…
Reference in a new issue