Noted in luasec 0.4.1 Changelog: Activate SSL_MODE_RELEASE_BUFFERS by default if it is available (thanks Prosody project) Update to latest 0.5 to fix a few other leaks. luasec moved to github, so update URL and license info. Move package maintainer to correct place in Makefile, hope he is okay with it. Signed-off-by: Stefan Hellermann <stefan@the2masters.de>
20 lines
431 B
Diff
20 lines
431 B
Diff
--- luasec-luasec-0.5-old/src/luasocket/Makefile 2014-01-29 21:43:33.000000000 +0100
|
|
+++ luasec-luasec-0.5/src/luasocket/Makefile 2014-11-30 13:07:44.850051000 +0100
|
|
@@ -6,7 +6,7 @@
|
|
|
|
CC ?= cc
|
|
CFLAGS += $(MYCFLAGS) -DLUASOCKET_DEBUG
|
|
-AR := ar rcu
|
|
+AR ?= ar
|
|
RANLIB ?= ranlib
|
|
|
|
.PHONY: all clean
|
|
@@ -14,7 +14,7 @@
|
|
all: libluasocket.a
|
|
|
|
libluasocket.a: $(OBJS)
|
|
- $(AR) $@ $(OBJS)
|
|
+ $(AR) rcu $@ $(OBJS)
|
|
$(RANLIB) $@
|
|
|
|
clean:
|