Fixes python3 host SSL build -> host-pip can use https:// urls again. Updates Pip to 10.0.1 rebased patches Signed-off-by: Martin Strobel <arctus@crza.de>
18 lines
925 B
Diff
18 lines
925 B
Diff
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1381,6 +1381,7 @@ libinstall: build_all $(srcdir)/Modules/
|
|
$(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \
|
|
$(DESTDIR)$(LIBDEST); \
|
|
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
|
+ifeq (@COMPILE_ALL_TESTS@,yes)
|
|
if test -d $(DESTDIR)$(LIBDEST)/distutils/tests; then \
|
|
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
|
|
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
|
|
@@ -1416,6 +1417,7 @@ libinstall: build_all $(srcdir)/Modules/
|
|
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
|
|
+endif
|
|
|
|
python-config: $(srcdir)/Misc/python-config.in Misc/python-config.sh
|
|
@ # Substitution happens here, as the completely-expanded BINDIR
|