This is to make explicit the conditional select of libunwind is only needed for libopenvswitch. If we spill it over other packages, the generated kconfig will have recursive dependency issue. 2 new patches were made for this goal The other thing is that "+libunwind" will cause it to be built if any of the packages defined in this Makefile is enabled (y or m). This is at the moment by-design of the build system. Libunwind does not support architectures like arc. Use conditional select To avoid (libunwind) build failures like the following, checking for ELF helper width... configure: error: Unknown ELF target: arc make[3]: *** [Makefile:65: /data/openwrt/build_dir/target-arc_arc700_uClibc/ libunwind-1.3.1/.configured_68b329da9893e34099c7d8ad5cb9c940] Error 1 Things like "+PACKAGE_openvswitch-libopenvswitch:libunwind" will also result in recursive deps error for chains of 3 nodes. Kconfig construct like the following will be made config A tristate select B depends on !(C) || (x) config B tristate select C config C tristate config x bool Other changes include - Shared use of variable ovs__common_depends was removed - Ovn doc build was patched out Link: https://github.com/openwrt/packages/pull/12959#issuecomment-665021413 Reported-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
22 lines
633 B
Diff
22 lines
633 B
Diff
From f3cc8c83993486b9d35557f2bd85038d5bb96bc5 Mon Sep 17 00:00:00 2001
|
|
From: Yousong Zhou <yszhou4tech@gmail.com>
|
|
Date: Wed, 29 Jul 2020 20:09:56 +0800
|
|
Subject: [PATCH] build: skip check and use of libunbound
|
|
|
|
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|
---
|
|
configure.ac | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 2bcd1945b..ad550fff8 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -130,7 +130,6 @@ OVS_CHECK_LINUX_HOST
|
|
OVS_LIBTOOL_VERSIONS
|
|
OVS_CHECK_CXX
|
|
AX_FUNC_POSIX_MEMALIGN
|
|
-OVN_CHECK_UNBOUND
|
|
|
|
OVS_CHECK_INCLUDE_NEXT([stdio.h string.h])
|
|
AC_CONFIG_FILES([lib/libovn.sym])
|