During 4.2.1 version update support for subordinate IDs has been disabled. It was handled by: 1) Adding --disable-subordinate-ids to avoid: configure: error: cannot run test program while cross compiling 2) Adding patch 003-fix-disabling-subids.patch to avoid: usermod.c: In function 'process_flags': usermod.c:1364:10: error: 'vflg' undeclared (first use in this function) if ( (vflg || Vflg) ^ This commit adds a patch with a proper configure.in fix. We don't need to disable subordinate IDs anymore. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
16 lines
440 B
Diff
16 lines
440 B
Diff
--- a/src/su.c
|
|
+++ b/src/su.c
|
|
@@ -1090,8 +1090,12 @@ int main (int argc, char **argv)
|
|
|
|
if (fd >= 0) {
|
|
err = ioctl (fd, TIOCNOTTY, (char *) 0);
|
|
+ if (-1 == err && ENOTTY == errno) {
|
|
+ /* There are no controlling terminal already */
|
|
+ err = 0;
|
|
+ }
|
|
(void) close (fd);
|
|
- } else if (ENXIO == errno) {
|
|
+ } else if (ENXIO == errno || EACCES == errno) {
|
|
/* There are no controlling terminal already */
|
|
err = 0;
|
|
}
|