packages/net/miniupnpc/patches/300-add-listdevices-to-cmake.patch
Rosen Penev 6e68dcdb97
miniupnpc: Update to 2.1.20190408
Switched to CMake. This allows getting rid of several patches and hacks.

Added PKG_LICENSE information

Rearranged some stuff for consistency between packages.

Added some linked flags for smaller size. Saves around 500 bytes on MIPS.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-04-17 11:29:08 -07:00

21 lines
679 B
Diff

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,6 +66,7 @@ set (MINIUPNPC_SOURCES
connecthostport.c
portlistingparse.c
receivedata.c
+ listdevices.c
connecthostport.h
igd_desc_parse.h
minisoap.h
@@ -142,6 +143,10 @@ if (UPNPC_BUILD_SHARED)
add_executable (upnpc-shared upnpc.c)
target_link_libraries (upnpc-shared PRIVATE libminiupnpc-shared)
target_include_directories(upnpc-shared PRIVATE ${CMAKE_CURRENT_BINARY_DIR})
+
+ add_executable (listdevices listdevices.c)
+ target_link_libraries (listdevices PRIVATE libminiupnpc-shared)
+ target_include_directories(listdevices PRIVATE ${CMAKE_CURRENT_BINARY_DIR})
endif ()
endif ()