packages/net/unbound/patches/010-configure-uname.patch
Pascal Ernster e702a66058 unbound: update to 1.16.1
Maintainer: @EricLuehrsen
Compile tested: realtek/rtl838x, x86/64
Run tested: realtek/rtl838x, x86/64
Description: Update to 1.16.1

Signed-off-by: Pascal Ernster <git@hardfalcon.net>
2022-07-19 12:29:19 +03:00

14 lines
438 B
Diff

OpenWrt (modification):
Fix cross compile errors by inserting an environment variable for the
target. Use "uname" on host only if "UNAME" variable is empty.
--- a/configure.ac
+++ b/configure.ac
@@ -813,7 +813,7 @@ if test x_$ub_test_python != x_no; then
fi
fi
-if test "`uname`" = "NetBSD"; then
+if test "${UNAME:-`uname`}" = "NetBSD"; then
NETBSD_LINTFLAGS='"-D__RENAME(x)=" -D_NETINET_IN_H_'
AC_SUBST(NETBSD_LINTFLAGS)
fi