Patch removing multiarch paths from build should be applied only when Python is built for target, but not for host. When the paths are removed during host build, host python throws some ugly errors when importing some hashlib modules. Also it reports that modules crypt and nis failed to build (tested on Ubuntu 14.04 host). Signed-off-by: Jan Čermák <jan.cermak@nic.cz>
14 lines
499 B
Diff
14 lines
499 B
Diff
diff --git a/setup.py b/setup.py
|
|
index 1d1ae72..511aed5 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -444,7 +444,8 @@ class PyBuildExt(build_ext):
|
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
if cross_compiling:
|
|
self.add_gcc_paths()
|
|
- self.add_multiarch_paths()
|
|
+ else:
|
|
+ self.add_multiarch_paths()
|
|
|
|
# Add paths specified in the environment variables LDFLAGS and
|
|
# CPPFLAGS for header and library files.
|