* Update package to 7.1.2 * Add Python 3 bindings package. The Python dependency is moved from seafile-ccnet to python3-seafile-ccnet. * Refresh patches. The path to valac does not need to be patched in 010-Makefile.patch because $(STAGING_DIR_HOSTPKG)/bin is already in the path during package build. * Use SEAFILE_UCI_LOG_DIR and SEAFILE_UCI_SOCKET_DIR, which will be added to seafile-server * Install binaries to /usr/libexec instead of /usr/bin, to mirror an upcoming change in seafile-server * Clean up Makefile formatting * Add myself as a maintainer Signed-off-by: Jeffery To <jeffery.to@gmail.com>
16 lines
545 B
Diff
16 lines
545 B
Diff
--- a/lib/Makefile.am
|
|
+++ b/lib/Makefile.am
|
|
@@ -1,3 +1,4 @@
|
|
+include $(TOPDIR)/rules.mk
|
|
|
|
AM_CPPFLAGS = @GLIB2_CFLAGS@ -I$(top_srcdir)/include \
|
|
-I$(top_srcdir)/include/ccnet \
|
|
@@ -85,7 +86,7 @@ rpc_table.stamp: ${top_srcdir}/lib/rpc_t
|
|
@rm -f rpc_table.tmp
|
|
@touch rpc_table.tmp
|
|
@echo "[libsearpc]: generating rpc header files"
|
|
- @PYTHON@ `which searpc-codegen.py` ${top_srcdir}/lib/rpc_table.py
|
|
+ @PYTHON@ "$(STAGING_DIR)/usr/bin/searpc-codegen.py" ${top_srcdir}/lib/rpc_table.py
|
|
@echo "[libsearpc]: done"
|
|
@mv -f rpc_table.tmp $@
|
|
|