At the moment, LEDE buildbots are complaining with: -snip- ... libcanfestival/examples/TestMasterSlave/TestMasterSlave.c:50: undefined reference to `MasterMap1' TestMasterSlave.o: In function `InitNodes': ... -snap- Since we are only interessted in the library itself, skip compilation of the example code. This should both fix the build and speedup it a little bit. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
20 lines
454 B
Diff
20 lines
454 B
Diff
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -21,7 +21,7 @@
|
|
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
|
#
|
|
|
|
-all: objdictedit canfestival examples
|
|
+all: objdictedit canfestival
|
|
|
|
examples: canfestival driver
|
|
$(MAKE) -C examples all
|
|
@@ -44,7 +44,7 @@ driver:
|
|
install: canfestival driver
|
|
$(MAKE) -C drivers $@
|
|
$(MAKE) -C src $@
|
|
- $(MAKE) -C examples $@
|
|
+ #$(MAKE) -C examples $@
|
|
$(MAKE) -C objdictgen $@
|
|
ldconfig
|
|
|