packages/admin/atop/patches/010-makefile-missing-cflags.patch
Rosen Penev 699ccdd12f
atop: update to 2.6.0
Reordered some stuff in the Makefile for consistency between packages.

Refreshed patches.

Added a musl fix.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2021-01-20 20:21:41 -08:00

11 lines
370 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -33,7 +33,7 @@ VERS = $(shell ./atop -V 2>/dev/null
all: atop atopsar atopacctd atopconvert atopcat
atop: atop.o $(ALLMODS) Makefile
- $(CC) atop.o $(ALLMODS) -o atop -lncursesw -lz -lm -lrt $(LDFLAGS)
+ $(CC) $(CFLAGS) atop.o $(ALLMODS) -o atop -lncursesw -lz -lm -lrt $(LDFLAGS)
atopsar: atop
ln -sf atop atopsar